Поиск и замена значений с плюшками для 8.1

Администрирование - Поиск данных

125
Обработка "Поиск и замена значений" с ИТС. Доработки: возможность загрузки из таблицы (с использованием доработанной типовой загрузки из табличного документа), определение типа "на что заменять" при выборе конкретного значения "что заменять", удобный отбор объектов, в которых заменять ссылки, по типам объектов.

Обработка "Поиск и замена значений" с ИТС. Доработки:

1. Возможность загрузки из таблицы (с использованием доработанной типовой загрузки из табличного документа)

2. Определение типа "на что заменять" при выборе конкретного значения "что заменять"

3. Удобный отбор объектов, в которых заменять ссылки, по типам объектов.

4. Нормальное отображение типов заменяемых объектов.

5. Нормальное отображение типов объектов, в которых заменяются ссылки.

6. Увеличена прозрачность процесса замены ссылок (добавлен показ конкретного места замены в объекте). Пример информационного сообщения о замене ссылки:

Обрабатывается <> (Справочник ссылка: Сохранённые расшифровки АВР для клиентов)
 В <> ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в реквизите шапки "Договор контрагента"
Обрабатывается Акт сверки взаиморасчетов 00000000265 от 20.04.2009 14:44:02 (Документ ссылка: Акт сверки взаиморасчетов)
 В Акт сверки взаиморасчетов 00000000265 от 20.04.2009 14:44:02 ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в реквизите шапки "Договор контрагента"
 В Акт сверки взаиморасчетов 00000000265 от 20.04.2009 14:44:02 ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в реквизите "Договор" табличной части "По данным организации"
 В Акт сверки взаиморасчетов 00000000265 от 20.04.2009 14:44:02 ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в реквизите "Договор" табличной части "По данным организации"
Обрабатывается Платежное поручение входящее 00000000051 от 22.01.2009 16:54:34 (Документ ссылка: Платежное поручение входящее)
 В Платежное поручение входящее 00000000051 от 22.01.2009 16:54:34 ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в реквизите шапки "Договор контрагента"
 В Платежное поручение входящее 00000000051 от 22.01.2009 16:54:34 ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в реквизите "Договор контрагента" табличной части "Расшифровка платежа"
 В движениях Платежное поручение входящее 00000000051 от 22.01.2009 16:54:34 (Регистр бухгалтерии: Журнал проводок (бухгалтерский учет)) ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в субконто Кт №2
 В движениях Платежное поручение входящее 00000000051 от 22.01.2009 16:54:34 (Регистр накопления: НДС расчеты с покупателями) ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов)в измерении "Договор контрагента"
Обрабатывается РегистрСведенийКлючЗаписи.ЗначенияСвойствОбъектов (Регистр сведений ключ записи: Дополнительные свойства)
 В РегистрСведенийКлючЗаписи.ЗначенияСвойствОбъектов ссылка на Другой договор (Справочник ссылка: Договоры контрагентов) заменена на Договор № 28-12/07 от 28.12.2007 г. (Справочник ссылка: Договоры контрагентов) в "Объект"

7. Добавлена кнопка "Поменять местами" для выделенных строк таблицы заменяемых значений.

Планируется: оптимизация процесса замены ссылок, внедрение блока замены в регистрах сведений от tormozit (если автор разрешит).

01.09.09 - добавлена замена ссылок в предопределённых ТЧ ПВХ, спасибо RomikMf.

29.04.10 - исправлена ошибка, возникающая в нетиповых конфигурациях - вызов несуществующего общего модуля.

22.06.11 - для конвертации в 8.2 макет сохраняете как epf (это обычная обработка), конвертируете отдельно, загружаете обратно.

125

Скачать файлы

Наименование Файл Версия Размер
-
.epf 116,70Kb
08.09.14
2148
.epf 116,70Kb 2148 Скачать

См. также

Комментарии
Избранное Подписка Сортировка: Древо
1. WiseSnake 1766 14.07.09 18:42 Сейчас в теме
Спасибо! Думаю буду пользоваться, посему плюс...
А теперь вопросы по существу:
1. У типовой обработки есть бяка... иногда она не заменяет ссылки должным образом, Вы не правили алгоритм в связи с этим?
2. Что означает галочка "Koнтpoлиpoвaть кoppeктнocть"? Хочется услышать от разработчика и в коде смотреть лень ;)
3. При вызове справки... справка все время на заднем фоне, ИМХО баг с настройкой вывода формы...
3. e.kogan 1837 15.07.09 10:34 Сейчас в теме
(1)
1. Пока не правила. Думаю дорабатывать, возможно, за основу возьму http://infostart.ru/projects/1134/ . Обязательно буду выводить информацию, где конкретно заменено (имя реквизита/реквизита ТЧ/измерения и т.д.)
2. ОбменДанными.Загрузка=Истина
3. Не замечала, честно говоря. У меня всё нормально выводится.

(2) Ну так оно ж для юзверей в основном, а приведённая вами как-то на пользовательски понятную мало похожа )
4. e.kogan 1837 16.07.09 13:45 Сейчас в теме
(1) Кстати, а как именно не заменяет? В каких ситуациях?
7. RomikMf 60 19.08.09 20:37 Сейчас в теме
(4). Не заменяет в предопределенных табличных частях планов видов расчета. Я добавлял следующий код в функцию вВыполнитьЗаменуЭлементов в текст по замене в справочниках, ПВР и т.п:

// Обработаем предопределенные таблицы ПВР
Если Метаданные.ПланыВидовРасчета.Содержит(СтрокаТаблицы.Метаданные) Тогда

Если СтрокаТаблицы.Метаданные.ЗависимостьОтВидовРасчета <> Метаданные.СвойстваОбъектов.ИспользованиеБазыПланаВидовРасчета.НеИспользовать Тогда

// Базовые
Для каждого СтрокаТЧ Из Параметры.Объект.БазовыеВидыРасчета Цикл
Если СтрокаТЧ.ВидРасчета = Ссылка Тогда
СтрокаТЧ.ВидРасчета = ПравильныйЭлемент;
КонецЕсли;
КонецЦикла;

// Ведущие
Для каждого СтрокаТЧ Из Параметры.Объект.ВедущиеВидыРасчета Цикл
Если СтрокаТЧ.ВидРасчета = Ссылка Тогда
СтрокаТЧ.ВидРасчета = ПравильныйЭлемент;
КонецЕсли;
КонецЦикла;

КонецЕсли;

Если СтрокаТаблицы.Метаданные.ИспользованиеПериодаДействия Тогда

// Вытесняющие
Для каждого СтрокаТЧ Из Параметры.Объект.ВытесняющиеВидыРасчета Цикл
Если СтрокаТЧ.ВидРасчета = Ссылка Тогда
СтрокаТЧ.ВидРасчета = ПравильныйЭлемент;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЕсли;
9. e.kogan 1837 01.09.09 11:23 Сейчас в теме
2. German 1002 15.07.09 09:52 Сейчас в теме
>возможность загрузки из таблицы (с использованием доработанной типовой загрузки из табличного документа)... как аналогия http://main.1c-ei.ru/Articles/replacement
5. tormozit 4910 19.07.09 19:36 Сейчас в теме
(0) Я не против. Используй и улучшай.
6. e.kogan 1837 20.07.09 10:59 Сейчас в теме
(5) Спасибо, будет время - займусь.
8. Romanovfastov 28.08.09 15:06 Сейчас в теме
Спасибо все работает на ура.
10. detec 131 28.04.10 13:37 Сейчас в теме
Желательно было бы сразу сделать обработку универсальной, без допиливания.
11. e.kogan 1837 28.04.10 13:41 Сейчас в теме
12. detec 131 28.04.10 22:52 Сейчас в теме
(11)

При открытии в нетивовой конфигурации ругается на ОбщегоНазначения.
13. e.kogan 1837 29.04.10 09:51 Сейчас в теме
(12) О, спасибо. Сейчас поправлю.
14. IP43 305 14.05.10 15:37 Сейчас в теме
Скачал, поработал, понравилось. Потребовалось снова, не нашел, снова скачал... и о УЖАС я оказывается забыл плюсануть :)
15. Tailbone 21.05.10 10:39 Сейчас в теме
Плюс от меня однозначно, думал просто скачать навроде стандартной, потом допиливать ОбменДанными = Истина и шерстить регистры (чтоб доки не перепроводились). Всё это уже есть за что бальшое спасибо!!!

Единственный пустячок, незнаю может на моей нетиповой конфе (на типовых не проверял).

Если заменяемое значение найдено в константах, то обработка не понимает этого и в Форма.НайденныеСсылки.ДанныеСтроки.Данные = Неопределено, а так всё замчательно :D
16. Tokiy 16.02.11 18:41 Сейчас в теме
Спасибо! Скачал, проверил, все отлично!
17. toci 22.06.11 12:51 Сейчас в теме
Не конвертируется обработка под 82, точнее конвертация происходит, а макет под 82 не открывается.
{Форма.Форма.Форма(741)}: Ошибка при вызове метода контекста (Создать)
обр=ВнешниеОбработки.Создать(рИмяПутьФайла);
по причине:

по причине:
Ошибка подключения внешних метаданных
по причине:
Ошибка загрузки документа.
Внешняя обработка не может быть прочитана текущей версией программы.


как этот макет конвертнуть или может разработчик выложит поправленный вариант для 82?
Заранее, спсб.
18. e.kogan 1837 22.06.11 13:25 Сейчас в теме
(17) Макет сохраняете как epf (это обычная обработка), конвертируете отдельно, загружаете обратно.
49. Tohohoro 08.06.16 08:18 Сейчас в теме
(18) Добрый день! Извините за глупый вопрос, но каким образом можно сохранить макет как epf? Заранее спасибо!
Прикрепленные файлы:
50. e.kogan 1837 13.06.16 19:40 Сейчас в теме
19. toci 22.06.11 13:37 Сейчас в теме
20. cobroid 29.09.11 10:08 Сейчас в теме
Отличная разработка для бухов а то они часом не ведают чего подвешивают :)
21. Zoomby 29.09.11 10:16 Сейчас в теме
Хорошая работа. автору плюсик.
22. _iAlex 04.10.11 13:28 Сейчас в теме
Работает хорошо ! Автор молодец!
23. spryn 04.10.11 13:53 Сейчас в теме
24. Limbo23 05.10.11 01:12 Сейчас в теме
Отлично работает. Срочно нужно было.
25. ARL 279 17.10.11 12:41 Сейчас в теме
Отличные "плюшки". Раньше отменял проведение в транзакции у типовой оброботки - слишком много объектов по одной ссылке - памяти не хватало, а тут уже все сделано, и отбор весьма кстати. Добавил только индикацию количества найденных и отобранных ссылок, при больших количествах - видеть это приятно. Обработкой пользуюсь с удовольствием, автору - благодарность.
26. e.kogan 1837 20.10.11 10:42 Сейчас в теме
(25) индикацию количества я когда-то тоже добавляла, но, возможно, запуталась в версиях ;)
27. Acasta 1 30.10.11 20:56 Сейчас в теме
28. toci 31.10.11 01:04 Сейчас в теме
29. Юля21 08.11.11 12:48 Сейчас в теме
Спасибо за обработку!!! Пригодилась!!!
30. greyboy666 08.12.11 14:21 Сейчас в теме
Спасибо за обрботку! Пригодилась
31. trustgros 8 14.12.11 18:21 Сейчас в теме
Спасибо за обработку!!! Пригодилась как раз под нужную задачу
32. petrovaUL 18.01.12 08:29 Сейчас в теме
А если вместо ссылки на объект <Объект не найден> (76:9633 и т.д.) будет работать?
33. e.kogan 1837 18.01.12 12:33 Сейчас в теме
34. Ироида 8 22.01.12 00:14 Сейчас в теме
Очень пригодилась, спасибо огромное!
35. AlexShap 2 25.01.12 11:35 Сейчас в теме
Спасибо. Очень помогло в решении огрех бухгалтеров.
36. ivan07 25.01.12 13:44 Сейчас в теме
Отличная обработка. Большое спасибо автору. Теперь пользуюсь только ей
37. Luca 08.02.12 02:19 Сейчас в теме
Объясните тупому, как эту обработку заполучить? При попытке скачать - выдаёт кучу способов оплаты. В том числе предлагается купить в магазине. Но в магазине обнаружить её не получается.
38. nestorpetrovi4 13.02.12 17:56 Сейчас в теме
Отличная обработка, автору +++ , немногое переделал :
1.После обработки элемента справочника являющегося подчиненным другому справочнику ("Договоры контрагентов"), была необходимость выбирать его владельца ("Контрагента"), устанавливаю в форме выбора активную строку являющуюся владельцем предыдущих данных. На мой взгляд удобно ))))
39. tormozit 4910 19.02.12 02:35 Сейчас в теме
В подсистеме Инструменты разработчика в мощном инструменте "Поиск дублей и замена ссылок" были заимствованы некоторые идеи из этой обработки. Спасибо.
41. e.kogan 1837 20.02.12 13:09 Сейчас в теме
40. hamsar 5 19.02.12 02:41 Сейчас в теме
Спасибо за обработку буду пользоваться.
43. Totoro 538 21.07.12 01:16 Сейчас в теме
(0) Жаль поздно обнаружил, уже свою почти аналогичную сделал. Плюс однозначно.
Единственное замечание по (7) - я заменял значение вида расчета только если его уже не было в табличной части, иначе просто удалял строку с заменяемым значением. Чтобы не возникало лишних дублей.
Сделал выгрузку заменяемых значений в табличный документ (чтобы потом в КД использовать как таблицу соответствий). И при выгрузке/загрузке заменяемых значений из табличного документа использовал уникальные идентификаторы.
44. Release 31.07.12 15:30 Сейчас в теме
Добавлю и я плюс. Хотя, лично для меня, есть некоторые недоработки:
1. Нужно бы деактивировать кнопку "Выполнить замену значений", если таблица "ссылок" (нижняя) пуста (иначе вылазит ошибка) или если происходили какие либо изменения в таблице "замен" (верхней).
2. Хотелось бы, видеть список движений содержащих искомые ссылки. Опционально, т.к. увеличит время поиска.
Но, думаю, это я доделаю сам. Спасибо.
45. e.kogan 1837 31.07.12 16:07 Сейчас в теме
(44) А вроде делала уже п.1... Насчёт движений - при полном комментировании оно вроде отображается, где меняют.
Прикрепленные файлы:
ПоискИЗаменаЗначений_Расширенная.epf
46. vadimlp77 30 30.08.13 02:08 Сейчас в теме
Не работает (ошибка выполнения) если измерение регистра бухгалтерии не балансовое - ищет по "Измерение1" (например), а нужно "Измерение1Дт" и "Измерение1Кт". Для себя исправил - работает.
47. NickOmskiy2 49 21.05.15 11:41 Сейчас в теме
ошибка :
{Форма.Форма.Форма(221)}: Ошибка при вызове метода контекста (Найти)
СтрокаТабЧасти = ТаблицаНабора.Найти(Ссылка, Измерение.Имя);
по причине:
Неверное имя колонки

1С:Предприятие 8.3 (8.3.5.1517)
Бухгалтерия государственного учреждения, редакция 1.0 (1.0.33.8)
48. e.kogan 1837 21.05.15 16:53 Сейчас в теме
(47) NickOmskiy2, под 8.3 не тестила даже. Может не взлететь ввиду разницы платформ.
Оставьте свое сообщение