Сравнение документов любых конфигураций

Обработки - Универсальные обработки

Универсальная обработка сравнения документов

42
Обработка позволяет сравнить любые документы в 2-х базах с любыми конфигурациями по любым реквизитам по любым видам документов.

Обработка позволяет сравнить документы в двух базах, с любыми конфигурациями (например УТ-БП), при этом сравниваются только найденные реквизиты.

Поиск идет по уникальному идентификатору, если кому не подойдет, можете переделать на поиск по номеру (изменить придется 2-3 строки).

Обработка создавалась для проверки обмена и пресечения редактирования документов после выгрузки. Сравнивает любые документы, реквизиты и табличные части.

Работает с 8.1 - 8.2 в режиме обычного приложения. Можно выбрать как список видов документов для сравнения, так и конкретный вид документа, тогда появляется возможность настройки полей для отбора (реквизитов документа и ТЧ).

Работает быстро (Сравнивал на 10 тыс. документов, отрабатывала примерно 5 минут). 

42

Скачать файлы

Наименование Файл Версия Размер
Сравнение документов
.epf 35,44Kb
18.08.14
348
.epf 35,44Kb 348 Скачать

См. также

Комментарии
Избранное Подписка Сортировка: Древо
1. makas 44 19.08.14 12:00 Сейчас в теме
Обработка в базах SQL (УТ и БП) будет сравнивать документы?
2. Stavsles 50 19.08.14 14:23 Сейчас в теме
Да, там есть возможность выбора файловой или серверной базы.
3. ceramica 7 04.09.14 09:41 Сейчас в теме
А для УФ будет? Хотелось бы так, как тенденция всеобщего перехода на УФ прогрессирует
4. Stavsles 50 04.09.14 12:21 Сейчас в теме
(3) ceramica, В ближайшее время точно не будет. У меня не хватает времени взяться за переработку этой обработки. Но в будущем вполне возможно что сделаю.
5. Yimaida 34 09.09.14 14:01 Сейчас в теме
Добрый день.
Stavsles, опишите, пожалуйста, как идет сопоставление (сравнение) справочников. А так же как отрабатывается ситуация перемешивания строк в документах, т.е. когда поменялся порядок строк.
6. Stavsles 50 09.09.14 13:32 Сейчас в теме
(5) Yimaida,
Добрый день! Обработка сравнивает справочники по наименованию. Имеется возможность выбора реквизитов для сравнения, например если из одной базы документы перебрасываются в другую на другую организацию, то можно просто исключить этот реквизит из проверки и обработка не будет по нему искать различия. В случае, когда поменялся порядок строк обработка выдаст сообщение о том, что строки различаются, сопоставление идет по номеру. Посмотрев на подробный отчет вы можете легко понять, что кроме порядка ничего не поменялось.
8. dassin 31.07.15 08:58 Сейчас в теме
Спасибо за работу. Обработка пригодилась, хотя снимать галочки по полям было неудобно. В открывающемся диалоговом окне "Список полей для выбора" неплохо бы добавить возможность снятия пометок со всех полей (и наоборот), потому что по всем абсолютно полям не всегда нужно сравнивать. Зачем нужен раздел "дополнительные поля" совсем непонятно. :)
9. Stavsles 50 31.07.15 16:52 Сейчас в теме
(8) dassin,
Рад что обработка пригодилась! По галочкам в контексте моей задачи как раз необходимо было сравнение по всем полям, исключая лишь некоторые, поэтому о кнопке убрать все и отметить все я сразу и не подумал. Дополнительные поля необходимы для удобства просмотра найденных различий по документу непосредственно на форме обработки, в табличной части "Обнаруженные различия".
10. Tanka07 24.08.15 13:20 Сейчас в теме
Здравствуйте! Очень нужна данная обработка, но не могу с ней справиться, выдает ошибку:

{Форма.Форма.Форма(833)}: Ошибка при вызове конструктора (ComObject)
ComConnection = Новый ComObject(СтрокаВерсияКоннектора);
по причине:
Недопустимая строка с указанием класса

Пытаюсь сравнить две базы Бухгалтерия предприятия, редакция 2.0 (2.0.64.20)
Файловая версия
Пользователя указываю, он без пароля
Пробовала когда вторая база не запущена и когда запущена, ошибка одна и та же

Платформа: 8.2.19.102
Win 7
Прикрепленные файлы:
11. Tanka07 24.08.15 14:17 Сейчас в теме
Все работает. нужно было зарегистрирвоать comcntr.dll
12. mikepin 19.07.16 08:07 Сейчас в теме
13. armeec 12 19.07.16 16:43 Сейчас в теме
Проблемная часть обработки (стр. 240-256) (Превращает реквизит типа Счет плана счетов из ,например, "60.02" просто в "60" ->Число->Окр->Строка....):

ЗначениеПодключеннойБазы = ПодключеннаяБаза.String(ВыборкаДокументовПодключеннойБазы[Реквизит.Значение]);
//
//Если ЗначениеПодключеннойБазы = "Да" Тогда
// ЗначениеПодключеннойБазы = "истина";
//КонецЕсли;
//Если ЗначениеПодключеннойБазы = "Нет"
// Тогда ЗначениеПодключеннойБазы = "ложь";
//КонецЕсли;
Если Не(ЗначениеПодключеннойБазы = "истина" или ЗначениеПодключеннойБазы = "ложь") Тогда
Попытка
ЗначениеПодключеннойБазы = Число(ЗначениеПодключеннойБазы);
ЗначениеПодключеннойБазы = Окр(ЗначениеПодключеннойБазы,ВидДокументаОбъект.Реквизиты[Реквизит.Значение].Тип.КвалификаторыЧисла.РазрядностьДробнойЧасти);
ЗначениеПодключеннойБазы = Строка(ЗначениеПодключеннойБазы);
Исключение
КонецПопытки;

КонецЕсли;


14. Yha 28.02.17 08:15 Сейчас в теме
Сергей, попробовала добавить в ERP 2 (2.2.2.157) , программа не дает добавить обработку. На ERP не работает???

15. Stavsles 50 02.03.17 12:49 Сейчас в теме
(14) Обработка работает только в режиме обычного приложения.
16. German_Tagil 6 12.10.18 09:52 Сейчас в теме
Я понимаю что времени уже много прошло
все работает только одно но ...
при исправлении документа шапка документа стирается
табличная часть копируется

в Процедуре КонтекстноеМенюИсправитьДокумент(Кнопка)

ЗаполнитьЗначенияСвойств(ДокОбъект, ДокКомОбъект,,"Номер");
не заполняет реквизита

год назад подступался - было некогда сейчас решил добить
17. Stavsles 50 12.10.18 10:48 Сейчас в теме
(16) Кнопку исправления я так и не доделал. Т.к. привести нормально текст к типам разных баз, причем конфигурации могут быть различные, задача довольно сложная, да и не слишком полезная. Поэтому кнопка просто осталась рудиментом.
18. German_Tagil 6 12.10.18 11:07 Сейчас в теме
конфигурации одинаковые - но вот почему то не работает
19. Stavsles 50 18.10.18 13:13 Сейчас в теме
(18)Она и не будет работать. Я ее не доделал и не стал заморачиваться. Обработке уже добрых семь лет и главную функцию сравнения обработка выполняет. Если вам нужно, чтобы обработка еще и правила документы, просто допилите ее под свои нужды. Код все таки открытый).
Оставьте свое сообщение