Ведомость по расчетам с контрагентами для Бухгалтерии 3.0

Отчеты - Бухгалтерские

Отчет Ведомость по расчетам с контрагентами для 1С: Бухгалтерии редакция 3.0, с расшифровкой по документам, без сумм зачета авансов, на СКД

Отчет Ведомость по расчетам с контрагентами для 1С: Бухгалтерия редакция 3.0, в разрезе документов, без сумм зачета авансов (только сумма сумма самого документа).

Аналог ведомости по контрагентам в торговой конфигурации.

Скачать файлы

Наименование Файл Версия Размер
Rashety
.erf 11,38Kb
20.06.15
92
.erf 1.0 11,38Kb 92 Скачать

См. также

Комментарии
1. Азат Галимзянов (GASH) 09.02.15 13:56 Сейчас в теме
Отчет не добавляется в дополнительные отчеты - просьба исправить
2. FlexLiam (FlexL) 26 22.09.15 15:16 Сейчас в теме
неверные обороты выводит, если убрать разрез документов ...
а так спасибо отчет помог..
3. КФК ООО (kfk) 27.01.16 23:07 Сейчас в теме
А как сделать, чтоб в валюте договора выводились? У нас экспорт... Очень надо!
4. Андрей Пономарёв (AndreyPonom) 77 28.01.16 19:42 Сейчас в теме
В данном отчете такой опции нет. Для этого нужна будет доработка отчета.
5. Дмитрий Дмитрий (atlastpk) 07.02.17 11:51 Сейчас в теме
Не могу добавить этот отчет в дополнительные отчеты и обработки. Пишет: "... Возможно он не подходит для этой версии программы". У нас текущая версия - Бухгалтерия предприятия, редакция 3.0 (3.0.47.23) Исправьте пожалуйста.
Прикрепленные файлы:
6. яяя toppeadop (user619848_ctocopok) 09.12.17 11:14 Сейчас в теме
(5)Откройте любую базу в конфигураторе.
Откройте этот отчет в открывшемся конфигураторе.
Нажмите "Действия" - "Открыть модуль объекта".
Добавьте на чистой странице код:
Функция СведенияОВнешнейОбработке() Экспорт
    РегистрационныеДанные = Новый Структура;
    РегистрационныеДанные.Вставить("Наименование", "Ведомость расчётов с контрагентами");
    РегистрационныеДанные.Вставить("БезопасныйРежим", Истина);
    РегистрационныеДанные.Вставить("Версия", "1.0");
    РегистрационныеДанные.Вставить("Вид", "ДополнительныйОтчет");    
    РегистрационныеДанные.Вставить("Информация", "Ведомость по расчетам с контрагентами (сч 60 и 62)");
    ТаблицаКоманд = ПолучитьТаблицуСКомандами();
    ДобавитьКоманду(ТаблицаКоманд,
                    "Ведомость расчетов с контрагентами",
                    1,
                    "ОткрытиеФормы",
                    Истина,
                    "");
    
    РегистрационныеДанные.Вставить("Команды", ТаблицаКоманд);
    Возврат РегистрационныеДанные;
    
КонецФункции
Функция ПолучитьТаблицуСКомандами()
    
    Команды = Новый ТаблицаЗначений;
    Команды.Колонки.Добавить("Представление");
    Команды.Колонки.Добавить("Идентификатор");
    Команды.Колонки.Добавить("Использование");
    Команды.Колонки.Добавить("ПоказыватьОповещение");
    Команды.Колонки.Добавить("Модификатор");
    Возврат Команды;
    
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд,
                            Представление,
                            Идентификатор,
                            Использование,
                            ПоказыватьОповещение = Ложь,
                            Модификатор)

    НоваяКоманда                     = ТаблицаКоманд.Добавить();
    НоваяКоманда.Представление             = Представление;
    НоваяКоманда.Идентификатор            = Идентификатор;
    НоваяКоманда.Использование             = Использование;
    НоваяКоманда.ПоказыватьОповещение             = ПоказыватьОповещение;
    НоваяКоманда.Модификатор             = Модификатор;
    
КонецПроцедуры

Показать


Возможно, что-то лишнее, я не очень разбираюсь. Но такой механизм (взятый из другой обработки) позволил зарегистрировать этот отчет стандартными средствами 1С.
7. яяя toppeadop (user619848_ctocopok) 09.12.17 11:18 Сейчас в теме
Отчёт прекрасен.
Единственное, я бы сделал "двухколоночный" вариант.
Где в одной колонке было бы движение задолженности, а в другой - остаток после этого движение.
Скажем
ООО "Ромашка"
Приход денег 1000 1000
Отгрузка -550 450
ООО "Василек"
Оплата -1000 -1000
Поступ товаров 1200 200

Тогда, кстати, итого по всем контрагентам даст общую цифру, мы должны или нам должны больше.

Вопрос только в том, что считать "минусом", а что "плюсом" для целей такого отчёта.
Оставьте свое сообщение