ЭВОТОР: выгрузка и загрузка в онлайн кассу в соответствии с требованием 54-ФЗ (54ФЗ). 1С: 7.7 ТиС

Обмен - Загрузка и выгрузка в Excel

Выгрузка из 1C версии 7.7 ТиС (Торговля и Склад) в EXCEL для дальнейшей загрузки в кассы ЭВОТОР, с помощью обработки обмен через EXCEL ( которая выбирается на сайте ЭВОТОР в магазине приложений). Полная версия без ограничений. Демоверсия позволяет выгружать только 5 строк номенклатуры(группы товаров). Демоверсия обладает такими же характеристиками что и полная за исключением того, что выгружает 5 строк неважно чего группы или номенклатуры (текст обработки зашифрован). Если у вас одна позиция номенклатуры или 5 позиций без групп, тогда Демоверсия для Вас.

Все говорят,  что для работы с новыми кассами система 1C:7.7 не подходит, однако это не так.

Чтобы избежать расходов по переходу на  версию 1С:8.2 или 8.3 , можно по-прежнему оставаться на  1C:7.7 , для этого покупается касса ЭВОТОР  https://evotor.ru/ ,а также выгрузка из 1C:7.7 Торговля и Склад   и при этом не требуется связки 1C:7.7 и кассы.

Касса сама автономно работает в течении дня со сканером штрих кода, а загрузка товара в кассу осуществляется  с помощью выгруженного файла из 7.7 .

Обновление  цен и номенклатуры делается по средством  загрузки файла через web приложение обмен через excel которое доступно первый месяц бесплатно. ( выбирается наш выгруженный файл Excel).

Итого расходы разовые:

 Стоимость кассы ЭВОТОР ( 30 000 р) + Стоимость моей обработки 1C:7.7 1500 р (полная версия) и стоимость приложения (загрузка файлов из Excel) 0 р( первый месяц) = 31750 р.

Ежемесячные расходы за стоимость приложения загрузки файлов=250 рублей( данное приложение доступно в магазине ЭВОТОР).

Возможно внедрение и в другие конфигурации 1C:7.7 за дополнительную плату.

 

При покупке модуля техническая поддержка 1 месяц  бесплатно.

Гарантировано работает на релизе ТиС 7.70.957.

Причины купить

1) Экономия времени при заливке товаров в кассу особенно если позиций номенклатуры достаточно много.

2) Возможность выбора 2х типов цен при заливке товаров ( Розничных или Мелкооптовых ) для этого достаточно сделать переименование в типах цен на ( Розничные и Мелкооптовые).

3) Вы получаете все 3 версии обработки  по цене 1  , в данный момент доступна одна версия , но все кто сделает  сейчас заказ получат их бесплатно.

4) Данная версия обработки успешно протестирована на  действующем предприятии (релиз в ТиС 7.70.957) позиций более 35000 номенклатуры. 

5) Есть возможность протестировать обработку перед покупкой  ( для этого можно скачать демо версию  и компоненты ) и выгрузить  на примере 5 товаров.

Достоинства

Позволяет Вам выгружать номенклатуру, а также цены розничные или мелкооптовые в формате Excel для онлайн касс ЭВОТОР.

Для этого установите  соответствующую галку в программе. (для того чтоб выгружала нужный вид цен поправьте название в справочнике Типы цен на Розничные и Мелкооптовые  поиск идет по наименованию)

В ближайшем будущем будет выложена еще одна версия  обработки которая работает по другому алгоритму , если время на выгрузку вас чем то не устроило.

Также будущем будет выложена еще одна версия которая бьет файлы по 10 000 номенклатуры чтобы , загрузка в кассу ЭВОТОР проходила более шустрее.

Если у Вас номенклатуры более 75000 позиций то версия которая будет бить по 10 000 позиций ( описанная выше) как раз будет для Вас

При покупке продукта вы высылаете запрос на почту gevicer.e@mail.ru на получение лицензии.

ВАЖНО . ПЕРЕД ТЕМ КАК СТАРТОВАТЬ ОБРАБОТКУ  НЕОБХОДИМО  ДОБАВИТЬ В ПРОЦЕДУРУ ГЛОБАЛЬНОГО МОДУЛЯ В  Процедура ПриНачалеРаботыСистемы()

СЛЕДУЩИЕ СТРОКИ (выделены жирным и курсивом)

  

Процедура ПриНачалеРаботыСистемы()
    Перем Спр;


    // Выполняется при старте
    // При старте проверяем наличие компоненты "Оперативный учет" 1С:Предприятия

    //Добавляемые строки

   Если ЗагрузитьВнешнююКомпоненту(каталогиб()+"decoder.dll") = 0 Тогда
        Предупреждение("Недоступна компонента ""decoder.dll"".");
    Иначе
    
    КонецЕсли;

//КонецДобавляемыхстрок

Иначе будут сыпаться ошибки что процедура не обнаружена итп.

 

 

Затем вводите эту лицензию в форму и нажимаете кнопку отправить, а затем кнопку активировать .

После этого вы можете работать с обработкой 

 

 

 

 

 

 

Гарантия возврата денег

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

Скачать файлы

Наименование Файл Версия Размер
ЭВОТОР выгрузка и загрузка в онлайн кассу в соответствии с требованием 54-ФЗ ( 54ФЗ) 1С 7.7 ТиС: демо
.ert 225,85Kb
19.06.17
14
.ert 1.1.1 225,85Kb 14 Скачать бесплатно
Компоненты для работы файла , просто добавить в основной каталог базы
.zip 468,68Kb
19.06.17
22
.zip 468,68Kb 22 Скачать бесплатно
ЭВОТОР выгрузка и загрузка в онлайн кассу в соответствии с требованием 54-ФЗ ( 54ФЗ) 1С 7.7 ТиС:
12.09.2017
1500 руб.

Моментальная
доставка

ЭВОТОР выгрузка и загрузка в онлайн кассу в соответствии с требованием 54-ФЗ ( 54ФЗ) 1С 7.7 ТиС: Техническая поддержка на 3 мес
12.09.2017
500 руб.

См. также

Комментарии
1. Евгений Гадомский (gevicer) 83 19.06.17 17:11 Сейчас в теме
Качаем выгрузку в excel файл для кассы Эвотор из 1с 7.7 , она также является полноценной для организаций с небольшим количеством номенклатуры ( до 5 позиций если в корне справочника номенклатуры)
2. Сергей (Sergant) 19 20.06.17 11:13 Сейчас в теме
В Эвоторе есть возможность локальной загрузки файла формата АТОЛ. (Формат простой, выгрузка пишется быстро)
3. Евгений Гадомский (gevicer) 83 20.06.17 12:06 Сейчас в теме
(2) Для 8ки возможно, никто не спорит, попробуйте для 7.7 и для номенклатуры с 30 тыс позиций
5. Demetr Ds (00tv) 23.06.17 15:38 Сейчас в теме
Можно ссылку на документацию эвотора ? Искал решение в свое время.
У них ни слова о локальном обмене. Только через облако, REST API. Для 7-ки вообще нету.
Сергей если не трудно, подскажите ? Конкретный пруф можно, а то до дыр их доки зачитал.
Пока данной обработкой пользуемся. Если есть локальный вариант, это сильно выручило бы.
Но даже Эвоторовская Техподдержка сказала, что нет такой возможности. Обманывают наверное.
4. Demetr Ds (00tv) 23.06.17 15:34 Сейчас в теме
Выручила, 45000 в семерке в торговле. Пара точек. Руками не вариант.
6. Евгений Гадомский (gevicer) 83 28.06.17 14:38 Сейчас в теме
ВАЖНО . ПЕРЕД ТЕМ КАК СТАРТОВАТЬ ОБРАБОТКУ НЕОБХОДИМО ДОБАВИТЬ В ПРОЦЕДУРУ ГЛОБАЛЬНОГО МОДУЛЯ

Процедура ПриНачалеРаботыСистемы()

СЛЕДУЩИЕ СТРОКИ (выделены жирным и курсивом)

Процедура ПриНачалеРаботыСистемы()
Перем Спр;
// Выполняется при старте
// При старте проверяем наличие компоненты "Оперативный учет" 1С:Предприятия

//Добавляемые строки

Если ЗагрузитьВнешнююКомпоненту(каталогиб()+"decoder.dll") = 0 Тогда
Предупреждение("Недоступна компонента ""decoder.dll"".");
Иначе

КонецЕсли;


//КонецДобавляемыхстрок
7. Олег Лантратов (Oblomovo) 12.09.17 10:22 Сейчас в теме
Доброго! Не могу с сайта скачать бесплатно демку. Поддержка сказала звонить на горячую линию, они типа соединят с Вами. Если оффлайн не случиться... Вопросов 2. Как всё таки заполучить демку? Какая обработка из магазина ЭВОТОР работает с Вашей обработкой? У меня 7.7 самописка(((

По обработке ЭВОТОР разобрался, недосмотрел в описании. Вопрос остался по демке, и если всё будет нормально, по покупке
9. Евгений Гадомский (gevicer) 83 12.09.17 12:40 Сейчас в теме
Добрый день Олег , теперь демо- версия бесплатна, можете ее скачать , если будут вопросы по работе пишите , обработка может работать в любых конфигурациях где есть справочники номенклатуры и типы цен
10. Олег Лантратов (Oblomovo) 12.09.17 12:41 Сейчас в теме
Спасибо за оперативность, увидел
11. Евгений Гадомский (gevicer) 83 12.09.17 12:42 Сейчас в теме
12. Олег Лантратов (Oblomovo) 12.09.17 13:27 Сейчас в теме
Ну вот где-то так получилось. Куда идти?
Далее, у меня нет мелкооптовых и розничных. Есть только учётная в номенклатуре. На всякий переименовал ее в розничную
Прикрепленные файлы:
13. Евгений Гадомский (gevicer) 83 12.09.17 18:07 Сейчас в теме
Олег скорее всего у вас нет глобальных функций которые есть в типовой конфигурации ТиС (Торговли и Склад) необходимо их внести в глобальный модуль вашей конфигурации, пишите мне в личку я помогу их внедрить по удаленке , либо поправлю под вашу конфу свою выгрузку

вот что нужно ставить в глобальный модуль

//
//******************************************************************************
//  глПересчет(Сумма,ВалютаНач,ПоКурсуВалютыНач,ВалютаКон,ПоКурсуВалютыКон,ПоКратностиВалютыНач,ПоКратностиВалютыКон)
//
// Параметры:      
//	Сумма                - сумма, которую следует пересчитать
// 	ВалютаНач            - валюта (элемент справочника "Валюты"), из которой считаем
// 	ВалютаКон            - валюта (элемент справочника "Валюты"), в которую считаем
// 	ПоКурсуВалютыНач     - курс или дата курса валюты нач
// 	ПоКурсуВалютыКон     - курс или дата курса валюты кон
// 	ПоКратностиВалютыНач - кратность валюты нач
// 	ПоКратностиВалютыКон - кратность валюты кон
//
// Возвращаемое значение: 
//  Сумма, пересчитанная в другую валюту
//
// Описание: 
// 	Эта функция пересчитывает сумму из ВалютаНач и возвращает значение Сумма в 
// 	ВалютаКон в параметрах ПоКурсуВалютыНач и ПоКурсуВалютыКон могут передаваться
// 	либо сами курсы либо даты
//
Функция глПересчет(Сумма,ВалютаНач,ПоКурсуВалютыНач,ВалютаКон,ПоКурсуВалютыКон,ПоКратностиВалютыНач = 1,ПоКратностиВалютыКон = 1) Экспорт
	
	Если ВалютаНач = ВалютаКон Тогда
		// ну, тут и считать нечего...
		Возврат Сумма;
	КонецЕсли;

	ТипЗн=ТипЗначенияСтр(ПоКурсуВалютыНач);
	
	Если ТипЗн = "Число" Тогда
		КурсВалютыНач      = ПоКурсуВалютыНач;
		КратностьВалютыНач = ПоКратностиВалютыНач;
		КратностьВалютыНач = ?(КратностьВалютыНач = 0,1,КратностьВалютыНач);
		
	ИначеЕсли ТипЗн = "Дата" Тогда
		КурсВалютыНач      = глКурсДляВалюты(ВалютаНач,ПоКурсуВалютыНач);
		КратностьВалютыНач = глКратностьДляВалюты(ВалютаНач,ПоКурсуВалютыНач);
		
	Иначе
		Сообщить("глПересчет():Неверный тип параметра ПоКурсуВалютыНач!");
		Возврат Сумма;
		
	КонецЕсли;

	ТипЗн = ТипЗначенияСтр(ПоКурсуВалютыКон);
	
	Если ТипЗн = "Число" Тогда
		КурсВалютыКон      = ПоКурсуВалютыКон;
		КратностьВалютыКон = ПоКратностиВалютыКон;
		КратностьВалютыКон = ?(КратностьВалютыКон = 0,1,КратностьВалютыКон);
		
	ИначеЕсли ТипЗн = "Дата" Тогда
		КурсВалютыКон      = глКурсДляВалюты(ВалютаКон,ПоКурсуВалютыКон);
		КратностьВалютыКон = глКратностьДляВалюты(ВалютаКон,ПоКурсуВалютыКон);
		
	Иначе
		Сообщить("глПересчет():Неверный тип параметра ПоКурсуВалютыКон!");
		Возврат Сумма;
		
	КонецЕсли;

	Если (КурсВалютыНач = 0) 
	 ИЛИ (КурсВалютыКон = 0) Тогда
		Сообщить("При пересчете валюты обнаружен нулевой курс валюты "
		+?(КурсВалютыНач = 0,ВалютаНач,ВалютаКон));
		Возврат Сумма;
	КонецЕсли;

	Возврат Сумма * ((КурсВалютыНач / КратностьВалютыНач) / (КурсВалютыКон / КратностьВалютыКон));
	
КонецФункции // глПересчет()

//2 фунция

//******************************************************************************
// глОкруглить(Числ, ПорядокОкругления)
//
// Параметры:
//  Числ              - исходное число
//  ПорядокОкругления - элемент перечисления Порядки окгугления: 
//  "шаг" округления (0.01 (арифметическое), 0.01, 0.05, 0.1, 0.5, 1, 5, 10, 50, 100)
//
// Возвращаемое значение:
//  Округленное по заданному порядку значение
//
// Описание:
//  Округляет число вверх по заданному порядку. Т.е число 123.37 при порядке
//  округление 0.5 превратиться в 123.50, а число 0.1 при порядке округления
//  5 станет равным 5.
//  Если значение перечисления ОкрТочно, то округляет арифметически до 0.01
//
Функция глОкруглить(Числ, ПорядокОкругления) Экспорт
	Перем Рез;
	
	Если ПорядокОкругления = Перечисление.ПорядкиОкругления.ОкрТочно Тогда
		
		// арифметическое округление до 2-х знаков после запятой
		Рез = Окр(Числ, 2);
	Иначе
		// округление к верхней границе по заданному порядку
		
		// преобразуем порядок округления число
		Порядок			= Число(Строка(ПорядокОкругления));
		
		// вычислим количество интервалов, входящих в число
		КолвоИнтервал	= Числ / Порядок;
		
		// вычислим целое количество интервалов.
		КолвоИнтервалЦел= Цел(КолвоИнтервал);
		
		Если КолвоИнтервал = КолвоИнтервалЦел Тогда
			// Числа поделились нацело. Округлять не нужно.
			Рез	= Числ;
		Иначе
			Рез	= Порядок * (КолвоИнтервалЦел + 1);
		КонецЕсли;
		
	КонецЕсли;
	
	Возврат Рез;
КонецФункции // глОкруглить()

//3 функция


// глВернутьЦену1(Номенклатура, ТипЦены, ДатаЦены, ЦенаЦены, ЕдЦены, ВалЦены, НаценкаЦены, НайденнаяЦена) 
//
// Параметры: 
//  Номенклатура  - элемент справочника "Номенклатура"
//  ТипЦены       - элемент справочника "ТипыЦен"
//  ДатаЦены      - дата, на которую надо получить цену
//  ЦенаЦены      - переменная, которую надо заполнитиь значением (число) полученной цены
//  ЕдЦены        - переменная, которую надо заполнитиь значением 
//                  (элемент справочника Единицы) единицы, за которую дается цена
//  ВалЦены       - переменная, которую надо заполнитиь значением валюты, в которой выражена цена 
//  НайденнаяЦена - переменная, которую надо заполнить найденным элементом справочника цен
//
// Возвращаемое значение:
//  1 - если есть такая цена, пераметры цены заполнены
//  0 - нет такой цены
// -1 - есть только цены, помеченные на удаление
//
// Описание:
//  Формирует ценовые характеристики номенклатурной единицы по заданному типу цен. 
//
Функция глВернутьЦену(Номенклатура, ТипЦены, ДатаЦены = 0, ЦенаЦены = 0, ЕдЦены = 0, ВалЦены = 0, НаценкаЦены = 0, НайденнаяЦена = 0) Экспорт
	Перем ЦеныНоменклатуры;
	Перем Рассчетная;
	Перем НужныйТипЦен;
	Перем ЕстьУдаленные;
	
	
	Рез = 1;
	НайденнаяЦена = ПолучитьПустоеЗначение("Справочник.Цены");
	
	Если ПустоеЗначение(ДатаЦены) = 1 Тогда
		ДатаЦены = РабочаяДата();
	КонецЕсли;
	
	// Найдет или нужную цену в справочнике
	// если она рассчитывается, то найдем базовую цену 
	Рассчетная		= ТипЦены.Рассчитывается;
	НужныйТипЦен	= ?(ПустоеЗначение(Рассчетная) = 1, ТипЦены, ТипЦены.БазовыйТипЦен);
	
	ЦеныНоменклатуры= СоздатьОбъект("Справочник.Цены");
	ЦеныНоменклатуры.ИспользоватьВладельца(Номенклатура); 
	ЦеныНоменклатуры.ВыбратьЭлементы();
	
	Пока ЦеныНоменклатуры.ПолучитьЭлемент()  = 1 Цикл    
		Если ЦеныНоменклатуры.ТипЦен <> НужныйТипЦен Тогда
			Продолжить;
		КонецЕсли;
		
		НайденнаяЦена = ЦеныНоменклатуры.ТекущийЭлемент();
		
		Если ЦеныНоменклатуры.ПометкаУдаления() = 1 Тогда
			Рез = - 1; // Цена есть, но помечена на удаление
			Продолжить;
		Иначе
			Прервать;
		КонецЕсли;
		
	КонецЦикла;       
	
	Если ПустоеЗначение(НайденнаяЦена) = 1 Тогда
		
		// Нет такой цены
		Возврат 0;
	КонецЕсли;
	
	// Заполним все ценовые характериситики 
	
	// если не задана единица цены на эту дату, то потом придется обрабатывать случай нулевого коэффициента у  пустой единицы
	ЕдЦены		= НайденнаяЦена.Единица.Получить(ДатаЦены); 
	
	Если ПустоеЗначение(Рассчетная) = 1 Тогда 
		
		//Если цена не рассчитывается
		ЦенаЦены	= НайденнаяЦена.Цена.Получить(ДатаЦены);
	    //Рез=ЦенаЦены;
		// элемент справочника существует Валюту и Наценку возьмем из него
		ВалЦены		= НайденнаяЦена.Валюта;
		НаценкаЦены	= НайденнаяЦена.Процент;
	Иначе
		//Если цена рассчитывается
		БазоваяЦена 	= НайденнаяЦена.Цена.Получить(ДатаЦены);
		БазоваяВалюта	= НайденнаяЦена.Валюта;
		
		// Цены у базового типа могут отличаться
		ЦенаЦены    = глПересчет(БазоваяЦена, БазоваяВалюта, ДатаЦены, ТипЦены.Валюта, ДатаЦены);
		ЦенаЦены    = глОкруглить(ЦенаЦены * (100 + ТипЦены.Процент) / 100, ТипЦены.ПорядокОкругления);
	    
		// элемент справочника Цены не существует (расчетный). Валюту и Наценку возьмем из типа цены
		ВалЦены		= ТипЦены.Валюта;
		НаценкаЦены	= ТипЦены.Процент;
	КонецЕсли;
	
	Возврат Рез;
КонецФункции // глВернутьЦену()
Показать
Oblomovo; +1 Ответить
14. Олег Лантратов (Oblomovo) 25.09.17 09:27 Сейчас в теме
Спасибо огромное!!! За сутки адаптировать свою обработку к нашей "самописке" - громадный респект. Выгрузили уже несколько раз, всё прекрасно работает. Но.. есть и пожелания - выдать дерево номенклатуры, хотя бы первого уровня, есть группы, которые не участвуют в рознице, приходится удалять их вручную из Excel файла
15. Евгений Гадомский (gevicer) 83 25.09.17 09:43 Сейчас в теме
(14) Олег обращайтесь, рад что вам помог, в следующем релизе выпущу с деревом номенклатуры
Оставьте свое сообщение