1С и Ваш Кошелек

Программирование - Практика программирования

Описан с нуля процесс конфигурирования простого приложения учета личных финансов на базе платформы 1С Предприятие 8.3. Пошагово создаются подсистемы учета расходов и доходов, вкладов и накоплений, кредитов и долгов. В результате конфигурирования получается вполне работоспособное и полезное приложение для личного использования. Предполагается , что читатель имеет некоторое представление о платформе 1С Предприятие 8.3 и саму платформу установленной на компьютере. Cтатья будет полезна желающим освоить конфигурирование приложений на платформе 1С на реальном примере нужной для каждого программы. Прилагается тестовая конфигурация и тестовая база.

СОДЕРЖАНИЕ.

  1. Что будем делать.
  2. План реализации
  3. Реализация
  4. Что получилось

    Что будем делать

    Попробуем создать приложение на платформе 1С Предприятие 8.3 , в котором можно будет вести учет  личных финансов.

    Предполагается создать в программе учет текущих расходов и доходов по категориям, учет вкладов и накоплений , учет кредитов и долгов , учет личного имущества и налогов. Хотелось бы , чтобы  все эти разделы должны быть взаимосвязаны между собой, чтобы в любой момент можно было оценить свое финансовое состояние ( то есть , посчитать  накопления минус долги).

    Кроме того должны быть полезные вещи -  курсы валют, учет коммунальных платежей, некоторое планирование расходов / доходов, телефонная книга, справочник получателей коммунальных (и не только) платежей и пр.

    Во главу угла поставим использование различных “кошельков” (собственно кошельков, счетов, карт) в разрезе пользователей и валют. Постараемся, чтобы программа была простой , но в то же время функциональной.

    Для точной оценки своих финансов добавим разнообразные отчеты.

    Примем во внимание Систему стандартов и методик разработки конфигураций для платформы 1С : Предприятие 8 (в частности, Общие требования к конфигурации и Имена объектов метаданных конфигурации).

    План  реализации.

    Используем платформу 1С Предприятие 8.3  и новый интерфейс «Такси» с управляемыми формами.

    Пусть первоначально  в нашей конфигурации будут следующие разделы (подсистемы) :

         Документы

    Кошельки

    Накопления и имущество

    Кредиты и Долги

    Отчеты

    Справочники

    Регистры

    Сервис

    Для реализации задуманного нами алгоритма работы и возможностей программы  в нашей конфигурации предполагается   для начала сконфигурировать следующие объекты 1С:

    Перечисления:

    СостоянияКошельков

    ТипыКошельков

    СпособыДоходовРасходов              

    Справочники :

    РазделыРасходов

    НоменклатураРасходов

    РазделыДоходов

    НоменклатураДоходов

    Кошельки

    Накопления

    КредитыИДолги

    ВладельцыКошельков

    Валюты

    Документы :

    Доход

    Расход

    Перемещение        

    Регистры накоплений :

    ОстаткиДенежныхСредствПоКошелькам

    Регистры сведений :

    КурсыВалют

    Реализация.

    Приступим собственно к конфигурированию.

    Создадим пустую базу в конфигураторе, назовем ее «МОЙ КОШЕЛЕК» и организуем подсистемы указанные выше.  Для каждой подсистемы выберем рисунок из общих рисунков , предварительно создав набор общих рисунков  (Рис_1).

    Не буду описывать по шагам, как это сделать, поскольку по данному вопросу информации   хватает.  Сохраним конфигурацию и посмотрим результат на экране, запустив , собственно , Предприятие или режим Отладки из Конфигуратора (Рис_2).

    Глядя на этот  «чистый» лист  и начнем. 

    Расход и доход будем учитывать по «кошелькам» в качестве которых будут собственно кошельки с наличными деньгами, счета , открытые в различных кредитных (и не только) организациях и пластиковые карты. Кошельков можно заводить сколько хочешь в разрезе пользователей и валют.

    Перечень кошельков со своими реквизитами будет находиться в справочнике  Кошельки .

    До создания данного справочника сконфигурируем  сначала объекты конфигурации  1С перечисления  :

             СостоянияКошельков (с реквизитами  ДЕЙСТВУЕТ , ЗАКРЫТ, ЗАБЛОКИРОВАН,АРЕСТ,ПРОЧЕЕ);

             ТипыКошельков (с реквизитами НАЛИЧКА, ТЕКУЩИЙСЧЕТ, РАСЧЕТНЫЙСЧЕТ, ДЕПОЗИТНЫЙСЧЕТ, ВИРТУАЛЬНЫЙСЧЕТ,  СЧЕТФОРЕКС, КРЕДИТНАЯКАРТА, ДЕБЕТОВАЯКАРТА, ПЕНСИОННАЯКАРТА, ЗАРПЛАТНАЯКАРТА,ПРОЧЕЕ)

    и  объекты конфигурации 1С справочники  :

             ВладельцыКошельков ( без реквизитов)

             Валюты   (с реквизитами СимвольныйКод, ЦифровойКод)    

    Напомню, что у объекта конфигурации 1С справочник есть стандартные по умолчанию реквизиты : Код и Наименование. Их мы и будем использовать в простых справочниках. Не забудем также приписать сконфигурированные объекты к соответствующим подсистемам конфигурации.

    Теперь собственно можно уже сконфигурировать справочник Кошельки с реквизитами  :

    НомерСчета                                 Строка      25

    ВалютаКошелька                       СправочникСсылка.Валюты

    ТипКошелька                              ПеречислениеСсылка.ТипыКошельков

    ГдеОткрытКошелек                  Строка        100

    ВладелецКошелька                  СправочникСсылка.ВладельцыКошельков

    СостояниеКошелька                 ПеречислениеСсылка.СостоянияКошельков

    ДатаОткрытияКошелька         Дата 

    ДатаЗакрытияКошелька         Дата 

    Примечание                               Строка        100

    Видно , что часть реквизитов справочника Кошельки  -  это ссылки на заведенные ранее нами перечисления и справочники. Для оставшихся реквизитов указывается длина строк и формат чисел. Разместим этот справочник в подсистеме Кошельки. Сдеалаем данный справочник иерархическим.

    Вот как теперь выглядит конфигурация (Рис_3) :

    Сохраним конфигурацию. Теперь уже можно начать работать с созданной нами программой.    

    Запустим приложение и заполним справочники ВладельцыКошельков (Рис_4) , Валюты (Рис_5), Кошельки (Рис_6):

    Естественно, данные в справочниках заполняйте свои .

    Продолжим.

    Перед заведением нового объекта конфигурации 1С документа Доход  предварительно сконфигурируем справочники с именами:

    РазделыДоходов (без реквизитов) 

    НоменклатураДоходов (с одним реквизитом Раздел) (Рис_7):

    Сохраним конфигурацию и запустим приложение. Занесем в открытые вновь справочники несколько значений сначала в справочник РазделыДоходов  потом и в справочник НоменклатураДоходов (Рис_8, Рис_9) :

    Заведем также перечисления СпособыДоходовРасходов (НАЛИЧКА, БЕЗНАЛИЧНО, СНЯТИЕЧЕРЕЗБАНКОМАТ, ВНЕСЕНИЕЧЕРЕЗДЕПОЗИТОР, ПРОЧЕЕ)   и  ТипыДвиженияДенежныхСредств (ДОХОД, РАСХОД,  ПЕРЕМЕЩЕНИЕ).

    Ну вот теперь можно завести объект документ Доход  с реквизитами  (Рис_10):

    КошелекДохода                           СправочникСсылка.Кошельки

    ВалютаДохода                              СправочникСсылка.Валюты               

    СуммаДохода                               Число                  15,2

    СтатьяДохода                                СправочникСсылка.НоменклатураДоходов

    РазделДохода                              СправочникСсылка.РазделыДоходов               

    Примечание                                  Строка                 100

    У документа Доход создадим сами  форму документа (то есть добавим форму ФормаДокумента в раздел Формы) . Это понадобится в дальнейшем. Отметим, что по умолчанию в 1С формы создаются автоматически и , если вы не планировали что-то добавлять на форму , то нет необходимости ее создавать самому.

    Разместим документ Доход в подсистеме Документы.

    Для учета движения денежных средств по кошелькам сконфигурируем еще один новый объект конфигурации регистр накоплений с именем ОстаткиДенежныхСредствПоКошелькам с параметрами  (Рис_11):

    Измерения :

    Кошелек                                          СправочникСсылка.Кошельки

    Ресурсы :

    Сумма                                              Число                  15,2

    Реквизиты :

    ВалютаДоходовРасходов          СправочникСсылка.Валюты               

    СтатьяДоходовРасходов            Строка                 100

    Свяжем регистр накоплений ОстаткиДенежныхСредствПоКошелькам с документом Доход, указав в регистре накоплений  в разделе Регистраторы документ Доход, а  в документе, в разделе Движение в качестве регистра накоплений регистр ОстаткиДенежныхСредствПоКошелькам.

    Далее в свойствах документа в закладке Движение необходимо нажать кнопку Конструктор движения и в  графе Выражения для полей Регистра накоплений проставить соответствующие поля документа Доход (Рис_12):

    После нажатия кнопки ОК откроется окошко Модуль объекта документа Доход , в котором  автоматически создается код движения по регистру накоплений  (Рис_13):

            

    Доработаем документ Доход таким образом, чтобы при изменении (заполнении) поля СтатьяДохода автоматически заполнялось поле РазделДоходов (связь по справочнику НоменклатураДоходов) и при изменении (заполнении)  поля КошелекДохода автоматически заполнялось поле ВалютаДохода (связь по справочнику Кошельки. Для этого мы сами сформировали форму документа Доход и теперь надо в модуле формы написать некоторый код.

    Раскроем свойства поля формы документа СтатьяДохода , найдем событие При изменении и для этого поля ,щелкнув мышкой по значку лупы справа от поля , попадем в заготовку кода функции НоменклатураДоходаПриИзменении.  Пропишем здесь всего несколько строчек  кода  (и этого вполне достаточно).

     Вот код :

    &НаКлиенте

    Процедура СтатьяДоходаПриИзменении(Элемент)

           СтатьяДоходаПриИзмененииНаСервере();

    КонецПроцедуры

    &НаСервере

    Процедура СтатьяДоходаПриИзмененииНаСервере()

           Объект.РазделДоходов = Объект.СтатьяДохода.Раздел;

    КонецПроцедуры

    Аналогично добавим код и для поля формы документа КошелекДохода :

    &НаКлиенте

    Процедура КошелекДоходаПриИзменении(Элемент)

           КошелекДоходаПриИзмененииНаСервере();

    КонецПроцедуры

    &НаСервере

    Процедура КошелекДоходаПриИзмененииНаСервере()

           Объект.ВалютаДохода = Объект.КошелекДохода.ВалютаКошелька;

    КонецПроцедуры

    Кроме этого в свойствах полей РазделДоходов и ВалютаДохода уберем возможность выбора данных полей (поставив галочку «ТолькоПросмотр»). То есть эти поля будут для нас только информационными и будут заполняться только автоматически.

    Сохраним конфигурацию  и проверим работу документа Доход.

    Создадим  реальный документ Доход , например, на 1100 рублей по кошельку Кошелек RUR (Рис_14) :

    Поля ВалютаДохода  и РазделДоходов заполнились автоматически при заполнении полей КошелекДохода и СтатьяДохода.

    Проведем , закроем документ и посмотрим , что получилось.

    Видим , что в регистре сведений ОстаткиДенежныхСредствПоКошелькам появилась строка по данному кошельку, с текущей датой и суммой документа (Рис_15):

    Таким образом документ Доход работает так, как мы и хотели пока.

    Введем с помощью документов Доход начальные остатки по всем заведенным нами кошелькам, заполнив тем самым регистр накоплений ОстаткиДенежныхСредствПоКошелькам (Рис_16) :

      

    Для отображения текущих остатков кошельков сформируем сами и доработаем ФормуЭлемента и ФормуСписка для справочника Кошельки (Рис_17):

    Для ФормыЭлемента добавим в Реквизиты на форме реквизит ТекущийОстатокПоДаннымРегистра (Число).

    Мышкой перетащим данный реквизит в закладку Элементы на левой части формы. Здесь образуется элемент ТекущийОстатокПоДаннымРегистра (Поле ввода) (Рис_18):

    Далее в Модуле Формы Элемента добавляем следующий код  (Рис_19):

    Очевидно, что данный код выбирает текущий остаток данного кошелька из регистра накоплений. Теперь можно проверить работу ФормыЭлемента справочника Кошельки. В нашем приложении зайдем в справочник Кошельки и «щелкнем» например на строке  «Вклад до востребования».  На открытой форме элемента отображается текущий остаток кошелька «Вклад до востребования» выбранный автоматически из регистра накоплений ОстаткиДенежныхСредствПоКошелькам (Рис_20) :

    Форму списка справочника Кошельки доработаем немного по другому.  На форме списка «щелкните» правой кнопкой мыши на реквизите Список (Динамический список) в правой части формы и в Свойствах откройте свойство “Настройка списка” . Мы увидим  код запроса (полученный по умолчанию) для для данного списка .  В него необходимо дописать несколько строк для выбора текущего остатка кошелька из регистра накоплений (Рис_21) :

    Кроме этого надо перетащить реквизит ТекущиеОстаткиПоДаннымРегистра в левую часть формы на закладку Элементы (Рис_22):

    Вот как выглядит теперь наш список кошельков (Рис_23):

    С доходами пока закончим и примемся за расходы.

    Сделаем предварительные шаги , аналогичные уже сделанным ранее для документа Доход.

    Заведем простые справочники РазделыРасходов (без реквизитов)  и НоменклатураРасходов (с одним реквизитом Раздел).

    Приступим теперь собственно к созданию объекта документ Расход.

    Сконфигурируем документ Расход со следующими реквизитами (Рис_24):

    КошелекРасхода                         СправочникСсылка.Кошельки

    СуммаРасхода                             Число                  15,2

    ВалютаРасхода                            СправочникСсылка.Валюты               

    СтатьяРасхода                              СправочникСсылка.НоменклатураДоходов

    РазделРасхода                             СправочникСсылка.РазделыДоходов               

    Примечание                                  Строка                 100

    Свяжем регистр накоплений  ОстаткиДенежныхСредствПоКошелькам с документом Расход, указав в регистре накоплений  в разделе Регистратор документ Расход, а  в документе в разделе Движение в качестве регистра накоплений  ОстаткиДенежныхСредствПоКошелькам. Создадим сами ФормуДокумента, поскольку мы собираемся ее дорабатывать.

    Доработаем документ Расход таким образом, чтобы при изменении (заполнении) поля СтатьяРасхода автоматически заполнялось поле РазделРасходов (связь по справочнику НоменклатураРасходов) и при изменении (заполнении)  поля КошелекРасхода автоматически заполнялось поле ВалютаРасхода (связь по справочнику Кошельки.

    Раскроем свойства поля формы документа СтатьяРасхода , найдем событие При изменении и щелкнув мышкой по значку лупы справа от поля попадем в заготовку кода функции СтатьяРасходаПриИзменении.  Пропишем здесь  несколько строчек  кода.

     Вот код :

    &НаКлиенте

    Процедура СтатьяРасходаПриИзменении(Элемент)

           СтатьярасходаПриИзмененииНаСервере();

    КонецПроцедуры

    &НаСервере

    Процедура СтатьярасходаПриИзмененииНаСервере()

           Объект.РазделРасходов = Объект.СтатьяРасхода.Раздел;

    КонецПроцедуры

    Аналогично добавим код и для поля формы документа КошелекРасхода :

    &НаКлиенте

    Процедура КошелекРасходаПриИзменении(Элемент)

           КошелекРасходаПриИзмененииНаСервере();

    КонецПроцедуры

    &НаСервере

    Процедура КошелекРасходаПриИзмененииНаСервере()

           Объект.ВалютаРасхода = Объект.КошелекРасхода.ВалютаКошелька;

    КонецПроцедуры

    Кроме этого в свойствах полей РазделРасходов и ВалютаРасхода уберем возможность выбора данных полей (поставив галочку «ТолькоПросмотр») и изменив тип поля на «Поле надписи».  То есть эти поля будут для нас только информационными и будут заполняться только автоматически.

    Сохраним конфигурацию  и проверим работу документа Расход.

    Не забудем предварительно заполнить справочник РазделыРасходов (Рис_25):

    И справочник НоменклатураРасходов (Рис_26):

    Сделаем реальный  документ  Расход на сумму 99 рублей с кошелька Кошелек RUR (Рис_27):

    Поля ВалютаРасхода  и РазделРасходов заполнились автоматически при заполнении полей КошелекРасхода и СтатьяРасхода.

    Проведем , закроем документ и посмотрим , что получилось.

    В регистре накоплений ОстаткиДенежныхСредствПоКошелькам видим появившуюся строку (Расход) по данному кошельку, с текущей датой и суммой документа (Рис_28):

    Документ Расход работает правильно!

    Будем двигаться дальше .

    На очереди у нас создание документа Перемещение для обмена денежных средств между кошельками.

    Здесь следует обсудить вопрос разновалютности кошельков (у нас есть кошельки в рублях, долларах США и ЕВРО). Если денежные средства перемещаются между кошельками с одной валютой , то вопросов нет.

    А если один кошелек , например в рублях , а другой в долларах США, то у нас получается фактически обмен (конверсия) валют!  Естественно, при этом нам надо знать курс обмена валют на текущий момент.

    Доработаем нашу программу для работы с разными валютами.

    Для начала сконфигурируем новый объект конфигурации регистр сведений КурсыВалют с параметрами :

    Измерения :

    Валюта                                                                     СправочникСсылка.Валюты

    ДатаКурса                                                               Дата                

    Ресурсы :

    КурсВалюты                                                           Число                  12,4

    Реквизиты :

    Кратность                                                               Число                   8          

    ЦифровойКодВалюты                                        Число                   3

    СимвольныйКодВалюты                                   Строка                 3

    В разделе Основные регистра сведений укажем Периодичность :  В пределах секунды  и  Режим записи : Независимый  (Рис_29):

    Теперь вопрос – где нам брать курсы валют на конкретную дату?

    Используем еще один новый объект конфигурации внешняя обработка.  Для этого в конфигураторе в пункт Обработки добавим внешнюю обработку ЗагрузкаКурсовВалютЦБР.epf  (к сожалению автора этой обработки назвать не могу). Суть этой обработки – загрузка курсов валют с сайта http:\\web.cbr.ru   с помощью метода GetCursOnDate. Разместим обработку в подсистеме Сервис.

    Курсы загружаются в таблицу на форме внешней обработки (Рис_30):

      В имеющийся код внешней обработки (в модуле обработки) добавим свой код для загрузки курсов также и в заведенный нами регистр сведений КурсыВалют.  Вот доработанный код модуля обработки :

    &НаКлиенте

    Процедура ЗагрузитьВалюты(Команда)

          

           Если НЕ ЗначениеЗаполнено(ДатаЗагрузки) Тогда

                 Сообщить("Не выбрана дата загрузки!", СтатусСообщения.Важное);

                 Возврат;

           КонецЕсли;

          

           ТаблицаКурсовВалют.Очистить();

           ЗагрузитьКурсыВалют(ДатаЗагрузки);

    КонецПроцедуры

    Процедура ЗагрузитьКурсыВалют(фДатаЗагрузки)

          

           //Определения = Новый  

                       WSОпределения("http://www.cbr.ru/DailyInfoWebServ/DailyInfo.asmx?WSDL");

           //Прокси = Новый WSПрокси(Определения, "http://web.cbr.ru/", "DailyInfo",           

                       "DailyInfoSoap");

          

           //Создаем прокси для обращения к внешнему веб-сервису,

           // передаем в функцию URI пространства имен, имя сервиса, имя порта.

           Прокси = WSСсылки.CBR_DailyInfoWebServ.СоздатьWSПрокси("http://web.cbr.ru/", "DailyInfo", "DailyInfoSoap");

          

           //Получаем тип параметра, который передается в метод GetCursOnDate.

           ТипWSПараметра =

            Прокси.ФабрикаXDTO.Пакеты.Получить("http://web.cbr.ru/").Получить("GetCursOnDate");

           //Создаем параметр на основе типа и заполняем значение параметра On_Date.

           WSПараметр  = Прокси.ФабрикаXDTO.Создать(ТипWSПараметра);

           WSПараметр.On_Date  = фДатаЗагрузки;

          

           //Вызываем метод веб-сервиса, записываем результат в переменную КурсыВалют.

           КурсыВалют = Прокси.GetCursOnDate(WSПараметр);

           //Перебираем таблицу ValuteCursOnDate, каждое значение таблицы

           // добавляем в таблицу на форме (колонки заполняем соответствующими значениями).

           Для Каждого Элемент Из   

                   КурсыВалют.GetCursOnDateResult.diffgram.ValuteData.ValuteCursOnDate

               Цикл

                 НоваяСтрокаТЗ = ТаблицаКурсовВалют.Добавить();

                 НоваяСтрокаТЗ.НазваниеВалюты      = Элемент.Vname;

                 НоваяСтрокаТЗ.Номинал             = Элемент.Vnom;

                 НоваяСтрокаТЗ.ЦифровойКодВалюты   = Элемент.Vcode;

                 НоваяСтрокаТЗ.СимвольныйКодВалюты = Элемент.VChCode;

                 НоваяСтрокаТЗ.КурсВалюты          = Элемент.Vcurs;

                

           // наша вставка

           // запись в регистр сведений КурсыВалют

        Если Элемент.VChCode = "USD" или  Элемент.VChCode = "EUR"

             Тогда

               Выборка = Справочники.Валюты.Выбрать();

               ПОКА Выборка.Следующий() ЦИКЛ

                 Если Выборка.СимвольныйКод = Элемент.VchCode ТОГДА

                      СсылкаВалюта = Выборка.Ссылка;

                      ПРЕРВАТЬ;

                 КонецЕсли;

               КонецЦИКЛ;    

              НаборЗаписей = РегистрыСведений.КурсыВалют.СоздатьНаборЗаписей();

               НаборЗаписей.Отбор.Валюта.Установить(СсылкаВалюта);

               НаборЗаписей.Отбор.ДатаКурса.Установить(ТекущаяДата());

               ЗаписьРегистра = НаборЗаписей.Добавить();

               ЗаписьРегистра.Период = ТекущаяДата();

               ЗаписьРегистра.Валюта = СсылкаВалюта;

               ЗаписьРегистра.ДатаКурса = ТекущаяДата();

               ЗаписьРегистра.КурсВалюты = Элемент.Vcurs;

               ЗаписьРегистра.Кратность = Элемент.Vnom;

               ЗаписьРегистра.ЦифровойКодВалюты = Элемент.Vcode;

               ЗаписьРегистра.СимвольныйКодВалюты = Элемент.VChCode;

               НаборЗаписей.Записать(Истина);

           КонецЕсли;

          // конец нашей вставки

           КонецЦикла;

    КонецПроцедуры

    Для полной установки обработки необходимо еще добавить в конфигурацию объект WS-ссылка с указанным именем (Рис_31) :

    Курсы всех валют нам естественно не нужны. Будем загружать для начала доллары США и ЕВРО.  Автоматизации загрузки курсов пока нет, поэтому , чтобы не усложнять программу , раз в день , когда нам понадобятся курсы,надо загрузить их вручную.

    Вот как выглядит регистр сведений КурсыВалют после загрузки курсов (Рис_32):

    Теперь курсы валют у нас есть. 

    Сконфигурируем новый документ Перемещение с реквизитами:

    КошелекОткудаПеремещение         СправочникСсылка.Кошельки               

    ВалютаКошелькаОткуда                    СправочникСсылка.Валюты

    КошелекКудаПеремещение             СправочникСсылка.Кошельки

    ВалютаКошелькаКуда                        СправочникСсылка.Валюты

    СуммаПеремещения                           Число                  15,2

    КонвертированнаяСумма                  Число                  15,2

    КурсКонвертации                                 Число                  10,4

    Комиссия                                                Число                  12,2

    Примечание                                           Строка                 100

    Для учета движения денежных средств по документу Перемещение будем использовать тот же регистр накоплений ОстаткиДенежныхСредствПоКошелькам. Однако здесь возникает некоторая сложность – нам надо , чтобы в регистре накоплений при проведении документа появились две записи : приход (по кошельку КошелекКудаПеремещение) со своей валютой и расход (по кошельку КошелекОткудаПеремещение) со своей валютой.

    Конструктор движения автоматически создает код только для одной записи (например, по расходу). Движение по Приходу прийдется дописать самим.  Вот какой код у нас получился в итоге (Рис_33):

    Создадим сами Форму Документа для документа Перемещение, поскольку нам надо дополнительно автоматизировать заполнение некоторых полей документа. Нам надо, чтобы при заполнении полей КошелекКудаПеремещение и КошелекОткудаПеремещение автоматически заполнялись поля ВалютаКошелькаКуда и ВалютаКошелькаОткуда  .

    Это обеспечивается следующим кодом , который надо прописать в модуле формы документа (Рис_34):

    Изменим процедуру КошелекКудаПриИзмененииНаСервере() и добавим в модуль  Формы Документа документа Перемещение еще некоторый код :

    &НаСервере

    Процедура КошелекКудаПриИзмененииНаСервере()

           Объект.ВалютаКошелькаКуда = Объект.КошелекКуда.ВалютаКошелька;

           Валюта = Объект.ВалютаКошелькаКуда;

          Если Валюта = Объект.ВалютаКошелькаОткуда Тогда

                    Курс = 1;

                    Объект.КурсКонвертации =  Курс;

          КонецЕсли 

    КонецПроцедуры

    &НаКлиенте

    Процедура СуммаПеремещенияПриИзменении(Элемент)

           СуммаПеремещенияПриИзмененииНаСервере();

    КонецПроцедуры

    &НаСервере

    Процедура СуммаПеремещенияПриИзмененииНаСервере()

           Объект.КонвертированнаяСумма =  Объект.СуммаПеремещения / Объект.КурсКонвертации;

    КонецПроцедуры

    Пока  мы упростили задачу и сделали заготовку на будущее. Очевидно , что сейчас документ Перемещение можно использовать только для кошельков с одинаковой валютой.  И заполнять этот документ надо в следующем порядке : сначала заполнить поля КошелекКуда и КошелекОткуда , а только потом поле СуммаПеремещения.  При этом автоматически заполнятся поля ВалютаКошелькаКуда , ВалютаКошелькаОткуда, КурсКонвертации , КонвертированнаяСумма.

    Для проверки сделаем реальный документ Перемещение (Рис_35) :

    После проведения документа в регистре накоплений ДвижениеДенежныхСредствПоКошелькам появилось две записи (по расходу и приходу) , как  и полагается (Рис_36) :

    Для перемещения денежных средств между разновалютными кошельками документ Перемещение следует доработать.  Однако это отдельная задача , рассмотрим ее позже.

    Займемся теперь «накоплениями».

    Сконфигурируем справочник Накопления    с  реквизитами  :

    НомерСчета                                 Строка       25

    НомерДоговора                         Строка       50

    ВалютаНакопления                  СправочникСсылка.Валюты

    СрокДоговора                             Число         5

    Сумма                                            Число         15,2

    ГдеОткрыт                                    Строка        50

    ВладелецНакопления              СправочникСсылка.ВладельцыКошельков

    СостояниеСчета                          ПеречислениеСсылка.СостоянияКошельков

    ДатаОткрытия                            Дата 

    ДатаЗакрытия                            Дата 

    КошелекНакопления               СправочникСсылка.Кошельки

    Примечание                               Строка        100

    Поскольку «накопления» у нас это те же «кошельки» , поэтому в справочник Накопления добавлен реквизит КошелекНакопления (ссылка на кошелек в справочнике Кошельки) . Аналогично справочнику Кошельки сделаем на форме элемента справочника Накопления вывод текущего остатка накопления , который оперативно получается из регистра накоплений ОстаткиДенежныхСредствПоКошелькам. Процедура для получения текущего остатка в модуле формы элемента будет несколько изменена :

    &НаСервере

    Процедура ПолучитьТекущиеОстаткиПоНакоплениюНаСервере()

           Кошель = Объект. КошелекНакопления;

           Запрос = Новый Запрос;

           Запрос.Текст = "ВЫБРАТЬ

                  | ОстаткиДенежныхСредствПоКошелькамОстатки.Кошелек,

                  | ОстаткиДенежныхСредствПоКошелькамОстатки.СуммаОстаток

                  | ИЗ

                  | РегистрНакопления.ОстаткиДенежныхСредствПоКошелькам.Остатки(,Кошелек= &Кошелек)

                  | КАК ОстаткиДенежныхСредствПоКошелькамОстатки";

           Запрос.УстановитьПараметр("Кошелек", Кошель);

           Результат = Запрос.Выполнить();

           Если НЕ Результат.Пустой() Тогда

                        Выборка = Результат.Выбрать();

                 Выборка.Следующий();

                 ТекущийОстатокПоРегиструНакоплений = Выборка.СуммаОстаток;

           КонецЕсли;  

    КонецПроцедуры     

    Занесем , для примера, в справочник Накопления депозит  “Вклад до востребования”  (Рис_37) :

    В принципе справочник Накопления работоспособен.  Аналогичным образом можно добавить вывод текущего остатка по накоплению и на Форму списка справочника.

    У нас осталась пустой подсистема Кредиты и Долги. Перейдем к ней.

    Сконфигурируем справочник Кредиты  с реквизитами :

    СуммаКредита                              Число                15,2 

    ВалютаКредита                             СправочникСсылка.Валюты   

    ДатаОткрытия                               Дата

    Аннуитет                                         Число                 12,2

    ДеньПлатежа                                Число                 5

    СрокКредитаДней                       Число                5

    СрокКредитаМесяцев                Число                5

    СостояниеКредита                       ПеречислениеСсылка.СостояниеКошельков

    ГдеОткрытКредит                        Строка               100

    ВладелецКредита                        СправочникСсылка.ВладельцыКошельков

    ДатаОткрытия                               Дата

    ДатаЗакрытия                               Дата

    Примечание                                  Строка                100

    И табличной частью ГрафикПогашения

    ДатаПлатежаПоГрафику               Строка                10

    СуммаЕжемесячныйПлатеж       Число                  12,2

    СуммаПлатежаОсновнойДолг    Число                  12,2

    СуммаПлатежаПроценты             Число                  12,2

    ОстатокОсновногоДолгаГрафик  Число                 15,2

    Погашено                                           Строка                 50

    Для этого справочника создадим  сами форму элемента (Рис_38):

    Заведем в приложении для примера какой-то кредит (вы естественно заводите свой)  (Рис_39) :

    Табличная часть кредита у нас пока не заполнена. Обычно по кредиту банк (или другая организация) выдает график погашения в виде таблички Excel. Хорошо бы загрузить этот график в табличную часть кредита автоматически. Это можно сделать с помощью простой процедуры.

    Вот код процедуры :

    &НаКлиенте

    Процедура ЗагрузитьГрафикПогашения(Команда)

           ДиалогВыбора = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);

           ДиалогВыбора.Заголовок = "Выберите файл";

           ДиалогВыбора.Расширение = "xls";

          

           Если ДиалогВыбора.Выбрать() Тогда

                 ИмяФайла = ДиалогВыбора.ПолноеИмяФайла;

           КонецЕсли;

           Попытка

                 Excel = Новый COMОбъект("Excel.Application");

                 Excel.WorkBooks.Open(ИмяФайла);

                 Состояние("Обработка файла Microsoft Excel ...");

           Исключение

                 Сообщить("Ошибка при открытии файла с помощью Excel! Загрузка не будет произведена.");

                 Сообщить(ОписаниеОшибки());

                 Возврат;

           КонецПопытки;

           Попытка

                 Excel.Sheets(1).Select();

           Исключение

                 Excel.ActiveWorkbook.Close();

                 Excel = 0;

                 Возврат;

           КонецПопытки;

           Версия = Лев(Excel.Version,Найти(Excel.Version,".")-1);

           Если Версия = "8" Тогда

                 ФайлСтрок = Excel.Cells.CurrentRegion.Rows.Count;

                 ФайлКолонок = Макс(Excel.Cells.CurrentRegion.Columns.Count,13);

           Иначе

                 ФайлСтрок = Excel.Cells(1,1).SpecialCells(11).Row;

                 ФайлКолонок = Excel.Cells(1,1).SpecialCells(11).Column;

           КонецЕсли;

           График = ЭтотОбъект.Объект.ГрафикПогашения;

           Для НомерСтроки = 2 по ФайлСтрок Цикл

                 НоваяСтрока = График.Добавить();

                 Для НомерКолонки = 1 по ФайлКолонок Цикл

                        ТекущееЗначение = Excel.Cells(НомерСтроки,НомерКолонки).Text;

                        Если  НомерКолонки = 2 Тогда

                            НоваяСтрока.ДатаПлатежаПоГрафику = ТекущееЗначение;

                        КонецЕсли;

                        Если  НомерКолонки = 3 Тогда

                            НоваяСтрока.СуммаЕжемесячногоПлатежа = ТекущееЗначение;

                        КонецЕсли;

                        Если  НомерКолонки = 4 Тогда

                            НоваяСтрока.СуммаПлатежаОсновнойДолг = ТекущееЗначение;

                        КонецЕсли;

                        Если  НомерКолонки = 5 Тогда

                            НоваяСтрока.СуммаПлатежаПроценты = ТекущееЗначение;

                        КонецЕсли;

                        Если  НомерКолонки = 6 Тогда

                            НоваяСтрока.ОстатокОсновногоДолгаГрафик = ТекущееЗначение;

                        КонецЕсли;

                 КонецЦикла;

           КонецЦикла;

    КонецПроцедуры

    Мы с вами уже ранее сделали явной форму элемента справочника Кредиты. В модуле этой формы и разместим данную процедуру, для этого добавив команду ЗагрузитьГрафикПогашения.

    На форме элемента сформируем   кнопку “Загрузить график погашения” (просто перетащив мышкой команду в левое окошко формы) , с помощью которой и будем выполнять команду в приложении (Рис_40):

    Заготовим табличку Excel с графиком погашения. Разумеется табличка должна иметь столбцы , соответствующие полям табличной части ГрафикПогашения справочника Кредиты . Столбец Погашено должен быть пустым .

    Вот пример таблицы для загрузки (Рис_41):

    Данные должны размещаться в таблице со 2-й строки (так прописано в коде функции загрузки).

    Попробуем загрузить график по заведенному нами кредиту запустив приложение, открыв кредит и нажав кнопку Загрузить график погашения. В режиме диалога выберем нашу табличку. Смотрим табличную часть кредита и видим , что наши труды не пропали бесследно – график загружен (Рис_42) :

    Записываем и закрываем кредит.

    На первое время предлагаю отмечать ежемесячное погашение кредита в табличной части вручную, просто проставляя например,  ПОГАШЕНО  в графу Погашено табличной части  на конкретную дату платежа.           Если это вас не устроит, то вы можете легко создать , например, документ ПогашениеКредита, который и будет заполнять графы.

    Теперь можно выдохнуть и немного расслабиться. С созданной вами программой уже можно начинать работать по настоящему, то есть занести все ваши реальные данные (кошельки, счета , карты, вклады, кредиты ) и начать учитывать расходы!

    Что будем делать дальше?

    Попробуем несколько «оживить» нашу программу. Пусть при запуске выдается сообщение с некоторыми финансовыми результатами. Для этого предварительно накодируем несколько функций для работы с остатками кошельков. Естественно разместим их в модуле ОбщиеРасчеты

    Вот код :

        Функция ПолучитьОстатокКошелька(Кошелек) Экспорт

           Запрос = Новый Запрос;

           Запрос.Текст =

           "ВЫБРАТЬ

           |ОстаткиДенежныхСредствПоКошелькамОстатки.Кошелек.Наименование КАК Кошелек,

           |ОстаткиДенежныхСредствПоКошелькамОстатки.СуммаОстаток КАК Остаток

        |ИЗ

           |РегистрНакопления.ОстаткиДенежныхСредствПоКошелькам.Остатки

           |               КАК ОстаткиДенежныхСредствПоКошелькамОстатки

           |ГДЕ

           |ОстаткиДенежныхСредствПоКошелькамОстатки.Кошелек.Наименование = &Кошелек ";

           Запрос.УстановитьПараметр("Кошелек", Кошелек);

           Ост = 0;

           Результат = Запрос.Выполнить();

           ЕСЛИ НЕ Результат.Пустой() ТОГДА

                 Выборка = Результат.Выбрать();

                 Выборка.Следующий();

                 Ост = Выборка.Остаток;

           КОНЕЦЕСЛИ;  

           Возврат Ост;

        КонецФункции

        Функция ОстатокКошельковВсего () Экспорт

            Сумма = 0.00;

            Выборка = Справочники.Кошельки.Выбрать();

            Пока Выборка.Следующий () Цикл

                    Если Выборка.СостояниеКошелька = Перечисления.СостоянияКошельков.ДЕЙСТВУЕТ     

                    Тогда

                         ТекКошель = ПолучитьОстатокКошелька(Выборка.Ссылка);

                         ТекКурс = ПолучитьКурсВалюты(Выборка.ВалютаКошелька,ТекущаяДата());

                          ТекСумма = ТекКошель * ТекКурс;

                         Сумма = Сумма + ТекСумма;

                   КОНЕЦЕСЛИ;

                 КонецЦикла;

              Возврат Сумма;

           КонецФункции

    Для вывода сообщений при входе в программу добавим в Модуль управляемого приложения                                ( В конфигураторе – МойКошелек – по правой кнопке – Открыть модуль управляемого приложения)  процедуру ПриНачалеРаботыСистемы (Рис_43) :

    Сохраняем и обновляем конфигурацию и запускаем приложение .  После запуска на главной странице видим наши сообщения (Рис_44):

    Пойдем дальше.

    Для некоторого планирования наших доходов  и  расходов попробуем сделать что-то типа бюджета на год. Будем делать все максимально просто без наворотов.

    Для хранения плановых показателей бюджета будем использовать регистр сведений Бюджет , а фактические показатели (доход / расход) будем оперативно получать из регистра накоплений ОстаткиДенежныхСредствПоКошелькам.

    Предварительно заведем перечисление РазделыБюджета (ДОХОДЫ, РАСХОДЫ, НАКОПЛЕНИЯ, КРЕДИТЫ).

    Далее нам надо как-то связать справочники НоменклатураРасходов и НоменклатураДоходов  с нашими будущими статьями бюджета.  Для этого нам прийдется немножко исправить , то что мы раньше сделали.

    Объединим  справочники РазделыДоходов и РазделыРасходов в  один справочник СтатьиБюджета с реквизитом РазделБюджета (СсылкаПеречисление.РазделыБюджета). Перенесем в него   все строки из старых справочников  (Рис_45):

    Справочники РазделыДоходов и РазделыРасходов из конфигурации удалим. Теперь нам надо исправить в свойствах реквизита Раздел справочников НоменклатураРасходов и НоменклатураДоходов ссылку на СправочникСсылка.СтатьиБюджета. Аналогично надо исправить ссылки в документах Доход и Расход.                И соответственно из программы заполнить этот реквизит в вышеуказанных справочниках на новый (Рис_46) :

    И наконец , сконфигурируем  регистр сведений Бюджет с параметрами (Рис_47):

    Измерения :

    Месяц                                             Число                  2

    Статья                                             СправочникСсылка.СтатьиБюджета

    Ресурсы :

    СуммаПлан                                   Число                  15,2

    Реквизиты :

    Год                                                  Число                   4               

    РазделБюджета                          ПеречислениеСсылка.РазделыБюджета

    Занесем несколько строк в регистр сведений Бюджет (Рис_48):

    Теперь нам остается придумать какую-то форму  для одновременного вывода плановых показателей по соответствующим статьям нашего бюджета и реальных доходов/ расходов этим статьям, которые нужно оперативно получать из нашего регистра накоплений ДвижениеДенежныхСредствПоКошелькам

    Давайте  подумаем над этим , а пока перейдем к отчетам.

    Сделаем для примера несколько простых отчетов, которые позволят оценить наши финансовые «достижения». Будем использовать встроенную в 1С систему конструирования отчетов , что позволит нам вообще не писать никакого дополнительного кода.  Объяснять буду схематично, желающие могут прочитать про СКД сами.

    Первый  отчет  Диаграмма расходов.  

    Исходные данные для данного отчета получим из списка   документов Расход. В конфигураторе открываем нашу конфигурацию .  Пункт Отчеты – Добавляем новый отчет – называем ДиаграммаРасходов -  Открыть схему компоновки данных  -  Набор данных – Добавить – Конструктор запросов – Выбираем нужные нам поля таблицы (Рис_49) :

    Далее на закладке Ресурсы выбираем поле Сумма  -  Выражение Сумма(Сумма) -  Закладка Настройки – Отчет – Выбираем тип Диаграмма  - Конструктор настроек – Круговая диаграмма – закладка Другие настройки (Рис_50) :

    Другие настройки (которые определяют внешний вид диаграмма) выбирайте сами . Сохраняем конфигурацию. Не забудьте добавить наш отчет в подсистему Отчеты.

    В приложении проверяем работу отчета .  Идем в Отчеты – Диаграмма расходов – Сформировать.  Должно получиться что-то такое (Рис_51) :

    Когда у вас будет много разных расходов – диаграмма будет красивой!

    Еще один отчет ДвижениеСредствПоКошелькам . Здесь в качестве исходных данных будем использовать регистр накоплений ОстаткиДенежныеСредстваПоКошелькам (Рис_52):

    Настройки здесь будут немного другие (Рис_53):

    При запуске отчета из приложения получаем примерно вот такой результат (Рис_54):

    Третий отчет – ОстаткиДенежныхСредствПоКошелькам. Здесь тоже в качестве исходных данных будем использовать регистр накоплений ОстаткиДенежныеСредстваПоКошелькам (Рис_55):

    Настройки будут такие (Рис_56):

    При запуске отчета из приложения получаем вот такой результат (Рис_57):

    На этом данную статью я заканчиваю. 

    Теперь вы наверняка сможете сами дорабатывать ваше приложение Мой кошелек.

    Что мы не успели сделать?

    Не доработали  документ Перемещение для работы с разновалютными кошельками.

    Не сделали документ ПогашениеКредита.

    Не доделали до конца систему работы с Бюджетом.

    Не сконфигурировали Справочники : 

                                 Список дел (работа с текущими делами),

                                 Люди (телефонный справочник с возможностью отправки электронной почты),

                                 Имущество (с табличными частями Налоги и Рыночная стоимость),

                                 Показания приборов учета ,

                                 Реквизиты для перечислений,

                                 Оплата коммунальных услуг.

    Кроме того хорошо было бы сделать выход в Интернет и отправку электронной почты прямо из приложения.

    На главную страницу (Главное) , которая сейчас при входе в нашу программу пустая (кроме сообщений ничего нет), можно что-нибудь вывести , например,  курсы валют или наиболее часто используемый справочник.

    Практика показывает, что неплохой вариант – вывести на закладку Главное  список документов РасходДенежныхСредств или справочник Кошельки , поскольку занесение своих расходов – основная операция при работе с программой.

    Успехов вам!    

Скачать файлы

Наименование Файл Версия Размер
1С и Ваш Кошелек:
.cf 172,10Kb
27.07.17
0
.cf 1.01 172,10Kb Скачать
1С и Ваш Кошелек:
.dt 234,42Kb
27.07.17
1
.dt 1.01 234,42Kb 1 Скачать
1С и Ваш Кошелек:
.doc 4,15Mb
31.07.17
0
.doc 1.0 4,15Mb Скачать

См. также

Комментарии
1. Михаил С. (Milanick) 02.08.17 09:42 Сейчас в теме
Очень хорошее инструкция для практики. Почитал, сделал. :)

Еще бы такое же описание для мобильного приложения. Логично же , сделать для своей базы , мобильный клиент. Ушел в магазин, потратил деньги, зафиксировал ( с распознованием спс)...
2. Андрей Акулов (DrAku1a) 1209 03.08.17 04:33 Сейчас в теме
Прикольно получилось. И подробно расписано - за это респект!

На мобильном (андройд) - использую программу "Vizi бюджет", там основное есть (кошельки, доходы, расходы, цели, бюджет и некоторые отчеты). Есть бесплатная и платная (купил), разница меж ними небольшая - только обмен с dropbox (удобно, кстати).
Я даже начал запиливать конфу в 1С, чтобы смотреть отчеты или делать глобальные правки в более удобной среде... Но "добро" от разработчиков на использование их продукта (даже в бесплатной версии конфы) - так и не получил.

Так вот, в процессе забивания финансов я столкнулся с тем, что время от времени - забываю оперативно внести расходы/доходы, и нужен документ "Инвентаризация денежных средств". В приложении есть функция "Изменить баланс", и она работает нормально - создаёт "проводку" с категорией "Правка баланса", но хочется даже большего. Нужен документ по типу документа "Инвентаризация товаров", но для денег, "Инвентаризация счетов", в котором забиваются реальные остатки, "подтягиваются" текущие и документ делает несколько проводок "Правка баланса", при этом - чтобы была возможность после внесения задним числом доходов/расходов (ну, вспомнилось) - обновить остатки до инвентаризации и проводки по правке баланса.
Может, пригодиться.

spogo; dajen; +2 Ответить 1
3. Яков Коган (Yashazz) 2103 03.08.17 09:14 Сейчас в теме
Ёёё. Ещё одно?.. И не надоело же народу... Каждый одинэсник, мало-мальский освоивший конфигурирование, начинает для себя лепить эдакий кошелёк. И почему-то эта идея через некоторое время загибается... Почему бы? И сами не ведём, и другим пофигу) Но, со времён 7.5 и по сию пору не оскудевает поток этих баянов)))
user633533_encantado; rayastar; +2 2 Ответить 2
4. Александр Васильев (user633533_encantado) 2 03.08.17 10:55 Сейчас в теме
"Управляемые блокировки ?" - не , не слышал.
5. Григорий Петров (user808217) 03.08.17 21:30 Сейчас в теме
Благодарю за труд. Прошу рассмотреть возможность реализации для мобильного приложения.
6. Александр Крынецкий (echo77) 740 04.08.17 09:46 Сейчас в теме
(0) Не понимаю, зачем такая детализация: РазделыРасходов, НоменклатураРасходов, РазделыДоходов, НоменклатураДоходов, Статьи бюджета - не проще ли ввести один справочник Статей ДДС и сделать его иерархическим?

Жду публикацию по развитию конфигурации в сторону мобильного приложения.
7. Александр Крынецкий (echo77) 740 04.08.17 09:48 Сейчас в теме
(2) Посмотрите конфигурацию УЛФин и рабочий стол для нее, который я делал: http://infostart.ru/public/602254/
8. rjhev korum (корум) 310 04.08.17 10:39 Сейчас в теме
(3)
начинает для себя лепить эдакий кошелёк

Некоторые лепят "домашнюю библио/фильмотеку", но не суть.
и "лепят" не только 1с-ники, а многие программисты от визуал бейсика для excel до веб-разработчиков и сапёров.
Это такой продвинутый хелло ворлд, по обьёму как пакет лабораторных работ студентов вуза.
Большой плюс - хорошо знакомая предметная область, которую можно без усилий разложить на составляющие элементы конфигурации.
9. rjhev korum (корум) 310 04.08.17 10:43 Сейчас в теме
(6) странный вопрос для 1с-ника...

РазделыРасходов, НоменклатураРасходов

Разделы: обслуживание авто, фигня для дачи, домашний ремонт.
номенклатура: изолента.
одна номенклатура, которая расходуется на разные цели.
Иерархическим справочником не решить.
10. Александр Крынецкий (echo77) 740 04.08.17 11:51 Сейчас в теме
(9) Хотите детализацию до покупаемой номенклатуры - ваше дело, я не против. По своему опыту ведения учета в УЛФин хочу отметить, что такую детализацию ежедневно набивать надоедает довольно быстро. Честно говоря, даже укрупненно разбивать чек по статьям задача тоже муторная.
В своем рабочем столе для УЛФин планирую сделать ввод расходов по счетам на основе истории предыдущих покупок - чтобы оставалось только вписывать суммы по статьям по которым был расход с этого счета ранее
11. Александр Крынецкий (echo77) 740 04.08.17 11:53 Сейчас в теме
(3) А что нет то? Публикация хороша как практический учебник по теме. Вести учет именно в этой программе не обязывает, стоимость для скачивания - условная
12. Zixi (Zixi) 07.08.17 10:24 Сейчас в теме
Отличная статья! Для начала работы в 1С - очень даже хорошо: просто, понятно и доступно.
Хотелось бы увидеть завершение работы с Бюджетом.
13. Альтаир (Altair777) 638 07.08.17 11:31 Сейчас в теме
Сильно сомневаюсь, что подобный подход поможет стать программистом. Сидеть и тыкать в кнопочки по инструкции - это отнюдь не программирование.
Оставьте свое сообщение