Журнал учета материальных ценностей

Отчеты - Бухгалтерские

Отчет Журнал учета материальных ценностей. Обычные формы СКД. (проверено на КА 1 релиз 1.107.4)

1
Отчет "Журнал учета материальных ценностей" представляет из себя бланк для ручного заполнения. На СКД, обычные формы. Может быть использован как шаблон для собственных доработок. Изготовление отчета в виде шпаргалки приводится пошагово (проверено на КА 1, релиз 1.107.4)

Для создания отчета нам понадобится :

1.Запрос

ВЫБРАТЬ
	СУММА(ХозрасчетныйОстатки.КоличествоОстаток) КАК Количество,
	СУММА(ХозрасчетныйОстатки.СуммаОстаток) КАК Сумма,
	ВЫРАЗИТЬ(ХозрасчетныйОстатки.Субконто1 КАК Справочник.Номенклатура) КАК Номенклатура,
	ВЫРАЗИТЬ(ХозрасчетныйОстатки.Субконто2 КАК Справочник.Склады) КАК Склад,
	ОтветственныеЛицаСрезПоследних.ФизическоеЛицо КАК Кладовщик
ИЗ
	РегистрБухгалтерии.Хозрасчетный.Остатки(
			&ДатаОстатков,
			,
			&МассивСубконто,
			Субконто2 = &Склад
				И Организация = &Организация) КАК ХозрасчетныйОстатки
		ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Номенклатура КАК Номенклатура
		ПО ХозрасчетныйОстатки.Субконто1 = Номенклатура.Ссылка
		ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Склады КАК Склады
		ПО ХозрасчетныйОстатки.Субконто2 = Склады.Ссылка,
	РегистрСведений.ОтветственныеЛица.СрезПоследних(&ДатаОстатков, СтруктурнаяЕдиница = &Склад) КАК ОтветственныеЛицаСрезПоследних

СГРУППИРОВАТЬ ПО
	ВЫРАЗИТЬ(ХозрасчетныйОстатки.Субконто1 КАК Справочник.Номенклатура),
	ВЫРАЗИТЬ(ХозрасчетныйОстатки.Субконто2 КАК Справочник.Склады),
	ОтветственныеЛицаСрезПоследних.ФизическоеЛицо

УПОРЯДОЧИТЬ ПО
	Кладовщик,
	Склад,
	Номенклатура

2. В СКД на закладке Ресурсы выбираем Количество и Сумму, на закладке Параметры устанавливаем список доступных субконто. Макеты - заполняем поля группировок и таблицу.

На закладке Настройки настраиваем группировки, выбираем "Без оформления" и итогов.  Картинки прилагаются.

3. Создаем форму отчета. В форму добавляем реквизиты Организация, Склад и ДатаОстатков. Заполняем их при помощи общих процедур вашей конфигурации (В моем случае КА1).  Добавляем изменение Компоновки настроек при заполнении наших реквизитов.  В свойствах формы поле Результат должно ссылаться на табличное поле "Результат".


Процедура ПриОткрытии()
	ДатаОстатков = НачалоМесяца(ТекущаяДата());
	ДатаОстатковПриИзменении(ЭлементыФормы.ДатаОстатков);
	Организация = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию( глЗначениеПеременной("глТекущийПользователь"), "ОсновнаяОрганизация");
	ОрганизацияПриИзменении(ЭлементыФормы.Организация);
	Склад = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию( глЗначениеПеременной("глТекущийПользователь"), "ОсновнойСклад");
	СкладПриИзменении(ЭлементыФормы.Склад);
КонецПроцедуры

Процедура ДатаОстатковПриИзменении(Элемент)
	ПараметрДанных= КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("ДатаОстатков");
	ПараметрДанных.Значение = ДатаОстатков;
	ПараметрДанных.Использование=Истина;
КонецПроцедуры

Процедура ОрганизацияПриИзменении(Элемент)
	ПараметрДанных= КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Организация");
	ПараметрДанных.Значение = Организация;
	ПараметрДанных.Использование=Истина;
КонецПроцедуры

Процедура СкладПриИзменении(Элемент)
	ПараметрДанных= КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Склад");
	ПараметрДанных.Значение = Склад;
	ПараметрДанных.Использование=Истина;
КонецПроцедуры

4. В модуль отчета пишем следующее:


Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	СтандартнаяОбработка = Ложь;
	//Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;  
	// - Если сделать так, как показано выше(рекомендуют на некоторых ресурсах), то при изменении настроек в режиме клиента
	// этих изменений Вы не увидите, потому что настройки всегда будут по умолчанию. Как правильно - вариант ниже
	Настройки = КомпоновщикНастроек.ПолучитьНастройки(); 
	
	ДанныеРасшифровки = Новый ДанныеРасшифровкиКомпоновкиДанных; 
	
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;	
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);	
	
	ВнешнийНаборДанных = Новый Структура; 
	ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных; 
	ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки, ВнешнийНаборДанных, ДанныеРасшифровки); 
	
	ДокументРезультат.Очистить();
	
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент; 
	ПроцессорВывода.УстановитьДокумент(ДокументРезультат); 
	ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);
	ДокументРезультат.Автомасштаб = Истина;
	ДокументРезультат.ЧерноБелаяПечать = Истина;
	ДокументРезультат.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
	ДокументРезультат.ПовторятьПриПечатиСтроки = ДокументРезультат.Область(14,,15);

КонецПроцедуры

 

1

Скачать файлы

Наименование Файл Версия Размер
: Журнал учета материальных ценностей
.erf 14,45Kb
01.10.18
0
.erf 14,45Kb Скачать

См. также

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение