Обработка тестирования WEB-сервиса (WSDL)

Программирование - Инструментарий

65
Простая обработка для тестирования WEB-Сервиса

2016-02-14 Обновление.

Выложена обработка под тонкий клиент.

В функционале добавлена возможность работы с составными типами реквизитов. Для этого необходимо кликнуть на строку реквизита.

В случае если тип "простой" (пренадлежит схеме "http://www.w3.org/2001/XMLSchema"), то значение редактируется, в пративном случае открывается окно реадктирования списка атрибутов параметра метода.

Деклаймер

К сожалению, ОбъектXDTO это не всегда то, что описанно в синтаксис-помошнике и работа со сложными типами атрибутов может осложнятся в зависимости от сервиса.

в том случае, если это произошло и что-то не работает - пишите в личку или в комменты. Но обязательно приводите адрес сервиса, для которого обработка не работает.

Под толстый клиент

Обработку не удоляю, хотя она и не работает так как хотелось бы.

В ближайшее время перепишу и её.

65

Скачать файлы

Наименование Файл Версия Размер
Обработка под такси и ТК
.epf 16,85Kb
01.09.16
54
.epf 16,85Kb 54 Скачать
Обработка
.epf 11,85Kb
01.09.16
281
.epf 11,85Kb 281 Скачать

См. также

Комментарии
Сортировка: Древо
0. KurganPX 195 20.10.11 01:47 Сейчас в теме
Простая обработка для тестирования WEB-Сервиса


Перейти к публикации

1. Sam. 20.10.11 01:47 Сейчас в теме
Полезная штука. Сколько нервов потратил на отладку смежных задач - словами не передать. Чтобы свой веб-сервис проверить нужны уже знания не 1с-ские или такая обработка.
cleaner_it; KurganPX; +2 Ответить
2. IamAlexy 493 22.10.11 15:05 Сейчас в теме
есть же шикарный инструмент: http://www.soapui.org/
3. Збянтэжаны Саўка 238 25.10.11 16:47 Сейчас в теме
(2) Но ведь всегда интереснее и полезнее при изучении предмета, самому все разобрать по косточкам.
(0) Спасибо за обработку - поскольку примеры всегда полезнее правил, как сказал еще Ньютон, тем более таких куцых описаний от 1С (ну ей богу поубывавбы их за их руководства)).
KurganPX; Yakud3a; andrey1402; Трактор; +4 Ответить
4. KurganPX 195 25.10.11 18:14 Сейчас в теме
(3) Збянтэжаны Саўка,
Вот и я о том же, очень хотелось разобраться.
Кроме того, у нас сервисы в локалке подняты и снаружи до них не достучаться...
5. МимохожийОднако 120 26.10.11 07:43 Сейчас в теме
На что посмотреть, если в сообщении об ошибке: "SSL connect error"
6. МимохожийОднако 120 26.10.11 07:44 Сейчас в теме
+(5)Подробнее:
{Форма.Форма.Форма(19)}: Ошибка при вызове конструктора (WSОпределения)
ВСОпределение = Новый WSОпределения(АдресСервиса, Пользователь, Пароль);
по причине:
При создании описания сервиса произошла ошибка.
по причине:
Ошибка доступа к файлу по причине:
Ошибка работы с Интернет: Peer certificate cannot be authenticated with known CA certificates
..
7. KurganPX 195 27.10.11 19:56 Сейчас в теме
(5) МимохожийОднако,
Сталкивался с таким, 1С сохраняет сертификат, но не видит его в упор, честно говоря, не копал в этой области, на диске ИТС, сказано, что работать должно всё автоматом.
Завтра попробую проверить на своём сервере.
8. fierce 33 13.01.12 13:30 Сейчас в теме
Спасибо за обработку, вещь оказалась нужной. Т.к. web программисты постоянно валят все ошибки на кривость 1С, и можно самому убедиться, что сделано всё правильно
9. Atriumpr 27.02.12 16:21 Сейчас в теме
Артём!

Мне нужно написать приложение к 1С 8.2 Комплексная Автоматизация.
Приложение для расчёта стоимости изделия.
Возьмётесь?

С Уважением,
Александр Якубовский
Коммерческий Директор
ООО "Нержавеющие конструкции",
Санкт-Петербург ул.Салова д. 23,
Тел. (812) 677-40-41 многок.
тел/факс (812) 490-53-69
моб.тел. (812) 928-09-69
http://nergconstructions.spb.ru
10. klel 17.03.12 20:40 Сейчас в теме
Большое спасибо за обработку хорошая вещь!!! +
12. Ionmuerto 20.12.13 14:59 Сейчас в теме
Неверный формат wsdl мне необходимо исправить. Как wsdl написанную для cs и vb мне переделать для 1с 8 вебсервиса?
13. Bloood 17 23.12.13 12:21 Сейчас в теме
(12) Ionmuerto, сам столкнулся с такой проблемой. 1С ка очень чувствительна к стилю wsdl. Более менее она работает со стилем wsdl - document/literal. C rpc/encoded и с rpc/literal даже не пытайся интегрировать. Зря потратишь время. Сохраняй на лок комп. wsdl и там правь ее под стиль document/literal.
Прикрепленные файлы:
16. KroVladS 09.12.15 10:14 Сейчас в теме
(14) _root,
Ссылка не работает, если есть аналоги прошу поделиться.

15. Vovanich082 03.08.15 19:52 Сейчас в теме
Раньше можно было за коменты и публикации получать см, а теперь только бабло везде нужно!!! Жаль, что пока аналога не появилось бесплатного.
17. JohnyDeath 291 30.08.16 09:58 Сейчас в теме
Вываливает ошибку при выполнении метода веб-сервиса:

{ВнешняяОбработка.ТестированиеWSDLv3.Форма.Форма.Форма(159)}: Ошибка компиляции при вычислении выражения или выполнении фрагмента кода
_Результат = Вычислить(_АгрегатнаяСтрока);
по причине:
{(1,98)}: Ожидается символ ')'
{(1,98)}: Ожидается символ ')'
ВСПрокси.getOrganizationByName(ВСПрокси.ФабрикаXDTO.Создать(ТипыXDTO[0], мПараметров[0].Значение)<<?>> СоответствиеПараметровXDTO.Получить(1))


У метода getOrganizationByName два параметра
18. KurganPX 195 01.09.16 10:11 Сейчас в теме
(17) JohnyDeath,
Спасибо за замечание, исправил
19. milanse 32 07.08.18 13:17 Сейчас в теме
Добавил сохранение логина, пароля, иначе падала ошибка авторизации при выполнении метода.

		//Формируем агрегатную строку реквизитов
		
	ВСПрокси.Пользователь = Объект.Пользователь;
	ВСПрокси.Пароль = Объект.Пароль;
	



Добавил функционал форматирования типов дата, датавремя, строка (возможность многострочного ввода)


&НаКлиенте
Процедура ДеревоФункцийТаблицаПараметровЗначениеОткрытие(Элемент, СтандартнаяОбработка)
	ТекущееЗначение = Элементы.ДеревоФункцийТаблицаПараметров.ТекущиеДанные.Значение;
	ТекущийТип = Элементы.ДеревоФункцийТаблицаПараметров.ТекущиеДанные.Тип;
	Если ТекущийТип = "dateTime" Тогда
		ПоказатьВводДаты(Новый ОписаниеОповещения("ОкончаниеВвода",ЭтотОбъект,Неопределено),XMLЗначение(Тип("Дата"),ТекущееЗначение),,ЧастиДаты.ДатаВремя);
		СтандартнаяОбработка = ЛОЖЬ;
	ИначеЕсли ТекущийТип = "date" Тогда
		ПоказатьВводДаты(Новый ОписаниеОповещения("ОкончаниеВвода",ЭтотОбъект,Неопределено),XMLЗначение(Тип("Дата"),ТекущееЗначение),,ЧастиДаты.Дата);
		СтандартнаяОбработка = ЛОЖЬ;
	ИначеЕсли ТекущийТип = "string" Тогда
		ПоказатьВводСтроки(Новый ОписаниеОповещения("ОкончаниеВвода",ЭтотОбъект,Неопределено),ТекущееЗначение,,,Истина);
		СтандартнаяОбработка = ЛОЖЬ;
	КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ОкончаниеВвода(ВведенноеЗначение,ДополнительныеПараметры) Экспорт
	Если ВведенноеЗначение <> Неопределено Тогда
		Элементы.ДеревоФункцийТаблицаПараметров.ТекущиеДанные.Значение = XMLСтрока(ВведенноеЗначение);	
	КонецЕсли; 
КонецПроцедуры


Показать


Добавил обработку типа результата, иначе падало на возврате простых типов (строка, булево)

	//Выводим результат
	Объект.Результат = "";
	
	_Результат = Вычислить(_АгрегатнаяСтрока);
	
	Если ТипЗнч(_Результат) = Тип("ОбъектXDTO") Тогда
		ВремХМЛ = Новый ЗаписьXML; 

		//ПараметрыЗаписиXML = Новый ПараметрыЗаписиXML("UTF-8", "1.0", Ложь); 

		ВремХМЛ.УстановитьСтроку("UTF-8");
		//ВремХМЛ.ОткрытьФайл(КаталогВременныхФайлов() + Строка(Новый УникальныйИдентификатор), ПараметрыЗаписиXML); 

		ВремХМЛ.ЗаписатьОбъявлениеXML(); 

		ВСПрокси.ФабрикаXDTO.ЗаписатьXML(ВремХМЛ, _Результат); 

		Объект.Результат = ВремХМЛ.Закрыть(); 
	Иначе
		Объект.Результат = _Результат; 
	КонецЕсли;
Показать
Оставьте свое сообщение