Мобильное приложение, управление фокусом ввода. Тем, кто не смог победить с помощью "НачатьРедактированиеЭлемента"

Публикация № 969675

Программирование - Мобильные приложения

Мобильная платформа НачатьРедактированиеЭлемента фокус ввода ТекущийЭлемент фокус

47
Для того, чтобы пользователю не приходилось тапать по полю ввода, чтобы ввести в него значение с клавиатуры (или сканера штрихкода, что весьма актуально), разработчики 1С реализовали функцию "НачатьРедактированиеЭлемента", которая, по-хорошему, должна это делать программно. Однако, отрабатывает эта функция некорректно...

Для того, чтобы пользователю не приходилось тапать по полю ввода, чтобы ввести в него значение с клавиатуры (или сканера штрихкода, что весьма актуально), разработчики 1С реализовали функцию "НачатьРедактированиеЭлемента", которая, по-хорошему, должна это делать программно.

Однако, отрабатывает эта функция некорректно: достаточно изменить любой другой элемент управления на форме(изменить надпись, переключить текущую страницу или что-либо другое), и фокус ввода теряется без возможности вернуть его на место свойством "ТекущийЭлемент" формы и вызовом функции "НачатьРедактированиеЭлемента". Фокус просто ничего не слушается.

Три дня ломая голову над этой проблемой, нащупал быстрое и действенное решение, позволяющее вернуть фокус в то поле, которое нам нужно, и корректно вызвать функцию "НачатьРедактированиеЭлемента": для того, чтобы это сделать, нужно ПОСЛЕ всех изменений на форме отключить видимость необходимого нам поля ввода, затем снова включить, выставить это поле в качестве текущего, и уж только после этого вызвать функцию "НачатьРедактированиеЭлемента". Выполнять эти действия достаточно прямо &НаКлиенте. 

Я достаточно жестко "веду" пользователя своего приложения, постоянно указывая следующее действие (такая специфика приложения), и написал следующую процедуру, которую вызываю каждый раз по окончании всех действий на форме:

&НаКлиенте
Процедура ПодготовитьПолеВвода()
	ОчиститьПолеВводаНаСервере();
	Элементы.ПолеВвода.ОбновитьТекстРедактирования();
	Элементы.ПолеВвода.Видимость = Ложь;
	Элементы.ПолеВвода.Видимость = Истина;
	ЭтаФорма.ТекущийЭлемент = Элементы.ПолеВвода;
#Если МобильноеПриложениеКлиент Тогда	
	НачатьРедактированиеЭлемента();
#КонецЕсли
КонецПроцедуры


&НаСервере
Процедура ОчиститьПолеВводаНаСервере()
	ПолеВвода = "";
КонецПроцедуры

У меня поиск этого решения занял долгие два дня ломания головы о монитор.

Кстати, чур не смеяться над тем, зачем я хожу на сервер, чтобы очистить поле ввода. Это ухищрение нужно для того, чтобы можно было корректно очистить поле ввода на форме при отключенном автообновлении этого элемента. А это в свою очередь необходимо, чтобы поле ввода не "дурило" при изменении других элементов формы. В общем - всё непросто в мобильном приложении. Сырой продукт еще. Но нужный! Так что, мыши плакали и кололись...

Буду очень рад, если кому-то этот опыт пригодится!

PS: столкнулся с данной проблемой на последней на данный момент версией мобильной платформы: 8.3.13.45.

47

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. user623969_dusa 24.12.18 13:23 Сейчас в теме
желательно указывать версии платформ, на которых такая особенность проявляется - мобильный версий 10 11 и 12 ведут себя очень по-разному
2. Crazy_Max 52 24.12.18 13:30 Сейчас в теме
(1) Да, Вы правы, наверное.
Я столкнулся с этой проблемой на последней на данный момент моб. платформе: 8_3_13_45.
3. peterxx 20 24.12.18 15:11 Сейчас в теме
Спасибо! Тоже бился целый день с этим, а все оказалось проще, чем думается.
4. acanta 55 24.12.18 15:57 Сейчас в теме
Cпасибо, хорошая вещь. Интересно, вот в старых версиях во многих программах был режим "Помощника" или "Мастера". Например сначала открывается окно, в которое вводим наименование. Затем оно закрывается, открывается окно ввода адреса и номера телефона. И.т.п.
Вы считаете это удобным, или все-таки народ предпочитает заполнять данные по тем сведениям что есть в каком-то хаотичном порядке?
12. Crazy_Max 52 25.12.18 04:48 Сейчас в теме
(4)
ете это удобным, или


Считаю это уместным на моибльной платформе. Но, разумеется, всё зависит от задачи. В моем случае - ПО для ТСД, сам бог велел работать в режиме мастера.
5. CyberCerber 282 24.12.18 16:37 Сейчас в теме
Спасибо за подсказку, но для меня еще одна проблема с этим осталась...
В какой момент выполнять вашу функцию ПодготовитьПолеВвода()?
В сканерах для 1С сделано, что при считывании штрихкода передается F7 + ШК + Enter.
Вот как отловить это событие, если в МП нельзя вешать сочетания клавиш на кнопки?
18. markers 236 17.01.19 05:11 Сейчас в теме
(5)
ПодготовитьПолеВвода

Так-как в мобильном приложении F7 ни как не обрабатывается. вам проще сделать сразу активным поле ввода штрихкода (обсуждаемыми тут методами) и просто отрезать первый символ клавиши F7, либо проще вообще сканер перенастроить чтобы у него не было префикса
6. CyberCerber 282 24.12.18 17:11 Сейчас в теме
Ну и еще одна вечная проблема - это как убрать экранную клаву при сканировании
11. Crazy_Max 52 25.12.18 04:45 Сейчас в теме
(6)У меня в ТСД есть возможность отключить экранную клавиатуру. Настраивается в момент ввода в настройках самой экранной клавиатуры.
13. dewersia 329 25.12.18 09:04 Сейчас в теме
(6)Была подобная беда на smart droid. Для аппаратной клавиатуры сделал сервис перехватывающий нажатие клавиш и передающий событие в мобильное приложение. Собственно на форме отключил редактирование полей и обрабатываю только событие нажатия кнопки. Таким образом клавиатура не появляется, а ввод данных производится только с аппаратной клавиатуры. Костыль, но без них пока никак )
7. w.r. 212 24.12.18 18:13 Сейчас в теме
Извиняюсь за оффтоп, но почему многие программисты, примеры кода которых я здесь видел, любят обращаться к элементам текущей формы через ЭтаФорма, если работаешь с одной формой. Можно же написать вместо ЭтаФорма.ТекущийЭлемент просто ТекущийЭлемент
10. Crazy_Max 52 25.12.18 04:44 Сейчас в теме
(7)Отношу такие темы к холиварным.
8. MuI_I_Ika 627 24.12.18 18:35 Сейчас в теме
>У меня поиск этого решения занял долгие два дня ломания головы о монитор.

Улыбнуло, многие над этим месяцы убивают. Не удалось найти решение как сделать активным поле поиска для табличного поля?
9. Crazy_Max 52 25.12.18 04:43 Сейчас в теме
(8)Не стояло такой задачи, если честно. Но можно "повешать котелок на гвоздик": сделать своё поле поиска. Не?
16. MuI_I_Ika 627 25.12.18 10:33 Сейчас в теме
(9)
е стояло такой задачи, если честно. Но можно "повешать котелок на гвоздик": сделать своё поле поиска.


Не то что они сделали реально удобное, и свой костыль будет явно хуже.
14. dewersia 329 25.12.18 09:07 Сейчас в теме
Маленькое дополнение, метод рабочий, но при сложной форме если метод использовать при открытии формы, элемент не активируется, видимо из-за того, что еще не успевает отрисоваться. Получалось побеждать с помощью подключения обработчика ожидания.
Crazy_Max; +1 Ответить
15. Crazy_Max 52 25.12.18 09:27 Сейчас в теме
(14) Хм... Спасибо! Если столкнусь с такой проблемой, буду иметь ввиду!
17. markers 236 17.01.19 05:03 Сейчас в теме
Можно ещё проще:
	ПодключитьОбработчикОжидания("ЗапуститьАктивациюПоляШтрихкода", 0.00000001, Истина);

&НаКлиенте
Процедура ЗапуститьАктивациюПоляШтрихкода()

	ЭтаФорма.ТекущийЭлемент = Элементы.ПоискПоШтрихкоду;
	
	#Если МобильноеПриложениеКлиент Тогда
	 
		ЭтаФорма.НачатьРедактированиеЭлемента();
			
	#КонецЕсли

КонецПроцедуры // ЗапуститьАктивациюПоляШтрихкода()
Показать

Данная проблема возникает из-за того, что когда мы устанавливаем текущий элемент, форма так скажем ещё не активна и обработка установки текущего элемента просто не происходит. Данный же код выполняется когда уже форма готова и при этом не вносит каких-то заметных задержек. Мне кажется установка видимости медленней работает чем этот код.
PS: Сори, не заметил что в (14) уже посоветовали это
kabanoff; user1058933; Dilovar9; +3 Ответить
19. alexovik 17 22.01.19 23:24 Сейчас в теме
Это топик наверное все обсуждали именно мобильное приложение, так как я прочитал и попробывал сделать это на мобильном клиенте и через обработчик ожидание и без него, через видимости, как автор топика написал, все равно не работает установка курсора на штриход после считывания...
20. ioan9117 09.04.19 17:07 Сейчас в теме
(19) Не правда. Работает в мобильном клиенте. Только что сделал
вот код:

&НаКлиенте
Процедура ШКПриИзменении(Элемент)
	ШКПриИзмененииНаСервере();

	ЭтаФорма.ОбновитьОтображениеДанных();
	ЭтаФорма.Элементы.ШК.АктивизироватьПоУмолчанию = Истина; //*- не факт что надо
	ПодготовитьПолеВвода();
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ЭтаФорма.Элементы.ШК.РедактированиеТекста = Истина;
	ПодготовитьПолеВвода();
КонецПроцедуры

&НаКлиенте
Процедура ПодготовитьПолеВвода()
	ОчиститьПолеВводаНаСервере();
	Элементы.ШК.ОбновитьТекстРедактирования();
	Элементы.ШК.Видимость = Ложь;
	Элементы.ШК.Видимость = Истина;
	ЭтаФорма.ТекущийЭлемент = Элементы.ШК;
#Если МобильныйКлиент Тогда	
	НачатьРедактированиеЭлемента();
#КонецЕсли
КонецПроцедуры


&НаСервере
Процедура ОчиститьПолеВводаНаСервере()
	ШК = "";
КонецПроцедуры
Показать


работает 8.3.12
Оставьте свое сообщение